summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/maildir/maildir-2.2.3-r1.ebuild')
-rw-r--r--dev-ruby/maildir/maildir-2.2.3-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-ruby/maildir/maildir-2.2.3-r1.ebuild b/dev-ruby/maildir/maildir-2.2.3-r1.ebuild
index dd920095148a..9cb2005f0e1d 100644
--- a/dev-ruby/maildir/maildir-2.2.3-r1.ebuild
+++ b/dev-ruby/maildir/maildir-2.2.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRAINSTALL="README.rdoc"
@@ -14,17 +14,23 @@ DESCRIPTION="A library for reading and writing arbitrary messages in DJB's maild
HOMEPAGE="https://github.com/ktheory/maildir"
LICENSE="MIT"
-KEYWORDS="~amd64"
SLOT="2"
+KEYWORDS="~amd64"
IUSE="test"
ruby_add_bdepend "
test? ( >=dev-ruby/fakefs-0.3.2 dev-ruby/mail dev-ruby/shoulda dev-ruby/test-unit:2 )"
all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' Rakefile test/helper.rb || die
+ sed -e '/bundler/ s:^:#:' \
+ -e '/pride/ s:^:#:' \
+ -i Rakefile test/helper.rb || die
# Avoid tests that appear to need activesupport for .blank? support
sed -i -e '/add and remove flags/,/^ end/ s:^:#:' test/test_message.rb || die
sed -i -e '/be removed from flag list/,/^ end/ s:^:#:' test/test_maildir.rb || die
+
+ # Fix deprecations
+ sed -e 's/File.exists/File.exist/' \
+ -i test/test_message.rb || die
}