summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/nkf/nkf-0.2.0.ebuild')
-rw-r--r--dev-ruby/nkf/nkf-0.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/nkf/nkf-0.2.0.ebuild b/dev-ruby/nkf/nkf-0.2.0.ebuild
new file mode 100644
index 000000000000..130f9b05866b
--- /dev/null
+++ b/dev-ruby/nkf/nkf-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/nkf/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="nkf.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension for Network Kanji Filter"
+HOMEPAGE="https://github.com/ruby/nkf"
+SRC_URI="https://github.com/ruby/nkf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -e 's:__dir__:".":' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}