summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/Manifest4
-rw-r--r--dev-ruby/rack/files/rack-1.2.1-gentoo.patch13
-rw-r--r--dev-ruby/rack/files/rack-1.4.5-fix-test-ruby20.patch25
-rw-r--r--dev-ruby/rack/metadata.xml10
-rw-r--r--dev-ruby/rack/rack-1.4.6-r1.ebuild43
-rw-r--r--dev-ruby/rack/rack-1.4.6.ebuild43
-rw-r--r--dev-ruby/rack/rack-1.5.4-r1.ebuild42
-rw-r--r--dev-ruby/rack/rack-1.5.4.ebuild42
-rw-r--r--dev-ruby/rack/rack-1.6.2.ebuild46
-rw-r--r--dev-ruby/rack/rack-1.6.4.ebuild46
10 files changed, 314 insertions, 0 deletions
diff --git a/dev-ruby/rack/Manifest b/dev-ruby/rack/Manifest
new file mode 100644
index 000000000000..eb98e8edfac6
--- /dev/null
+++ b/dev-ruby/rack/Manifest
@@ -0,0 +1,4 @@
+DIST rack-1.4.6.gem 204800 SHA256 f65ad9022e83e6517d6e3e37cecb781cd172061e769068334bab142d3435f13d SHA512 c4b9ab76f16079d26a045811305a62f882230058fdcbc157e176d85db9c5cfb3e7e672cbd68136339a986bd643bf202307f7db51f4f1313ecf47a750254a13f3 WHIRLPOOL 859b0da71b162d153ae775830c220bceda0fe556582235adec8e28105157be743ec94f61673cdb517a5683543d976b517087c3f1fbd5a5b4977754d423e9c3fb
+DIST rack-1.5.4.gem 216064 SHA256 401f8725be81ca60a4c8366fca674a9f18e9bc577b6ad4f42c9f66d763107e6e SHA512 713c3815ff4d6c1f498b9d3081b1f1a8ea929712fa6fb045fafe8544552b9d9db448e5a9862a6d40c1a1769788538630b5142daec157efc0e19dc0490d74e638 WHIRLPOOL 6313b68b1852a7d464bf18d3564c5978482fcb344086f6d404dce2fa6d8ccfd4c32b69e6eca59eeb2c32481e8f5910d21af2ba9b7f4baf193e72c160f8925de4
+DIST rack-1.6.2.gem 227840 SHA256 89278d4842d0ecdd1e79cbf7a894dc86f976e6d25debc6814343298fd19ed017 SHA512 0f0cdd2e55bb03ea73ab6ba339ca6027b2072425323b685b3f71c0b739276ad8009ec7f00b0f3f87c07229ccb70325473d2ec03a1f82a3ddc6e6d9f5545948ff WHIRLPOOL 4897e9d2b6fadd090375a899d93a95f33269db02c1d5f78816deccc3fb4b3684b89409a106306e117412757c50643b6ecd574c89c1d7951d866f20f33b9598fd
+DIST rack-1.6.4.gem 228864 SHA256 455ec4545a54b40dae9937bc5f61ee0e32134191cc1ef9a7959a19ec4b127a25 SHA512 304a6ae21bfd38008fd7d147f82c44397f3a1d2e689bd01de689aedc6ea0e8784605207fd314bc796974edc5dfcab81636664ea2becb0489302999f99501d41a WHIRLPOOL e99b545a783eaf09bc1c0cf3b4abfafa3341980cfebf1840e25ab25d5801d911da7dfbb232f70df291b7494cc8f8c089fe8a654502aa808850801c02b1e481c6
diff --git a/dev-ruby/rack/files/rack-1.2.1-gentoo.patch b/dev-ruby/rack/files/rack-1.2.1-gentoo.patch
new file mode 100644
index 000000000000..82ea127a8cb7
--- /dev/null
+++ b/dev-ruby/rack/files/rack-1.2.1-gentoo.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/rack/rewindable_input.rb b/lib/rack/rewindable_input.rb
+index accd96b..d71fde6 100644
+--- a/lib/rack/rewindable_input.rb
++++ b/lib/rack/rewindable_input.rb
+@@ -94,7 +94,7 @@ module Rack
+ end
+
+ def filesystem_has_posix_semantics?
+- RUBY_PLATFORM !~ /(mswin|mingw|cygwin|java)/
++ RUBY_PLATFORM !~ /(mswin|mingw|cygwin|java)/ && RUBY_VERSION < '1.9.1'
+ end
+ end
+ end
diff --git a/dev-ruby/rack/files/rack-1.4.5-fix-test-ruby20.patch b/dev-ruby/rack/files/rack-1.4.5-fix-test-ruby20.patch
new file mode 100644
index 000000000000..7854b7e6e16a
--- /dev/null
+++ b/dev-ruby/rack/files/rack-1.4.5-fix-test-ruby20.patch
@@ -0,0 +1,25 @@
+From 0a74380d2e5157d94c7e9141242af33e5c0bf951 Mon Sep 17 00:00:00 2001
+From: Santiago Pastorino <santiago@wyeworks.com>
+Date: Sat, 29 Dec 2012 17:36:08 -0200
+Subject: [PATCH] Fix Ruby 2.0 build
+
+---
+ test/spec_chunked.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/spec_chunked.rb b/test/spec_chunked.rb
+index c81409f..12f2158 100644
+--- a/test/spec_chunked.rb
++++ b/test/spec_chunked.rb
+@@ -41,7 +41,7 @@ def chunked(app)
+ response.headers.should.not.include 'Content-Length'
+ response.headers['Transfer-Encoding'].should.equal 'chunked'
+ response.body.encoding.to_s.should.equal "ASCII-8BIT"
+- response.body.should.equal "c\r\n\xFE\xFFH\x00e\x00l\x00l\x00o\x00\r\n2\r\n \x00\r\na\r\nW\x00o\x00r\x00l\x00d\x00\r\n0\r\n\r\n"
++ response.body.should.equal "c\r\n\xFE\xFFH\x00e\x00l\x00l\x00o\x00\r\n2\r\n \x00\r\na\r\nW\x00o\x00r\x00l\x00d\x00\r\n0\r\n\r\n".force_encoding("BINARY")
+ end if RUBY_VERSION >= "1.9"
+
+ should 'not modify response when Content-Length header present' do
+--
+1.9.1
+
diff --git a/dev-ruby/rack/metadata.xml b/dev-ruby/rack/metadata.xml
new file mode 100644
index 000000000000..3522a5c25652
--- /dev/null
+++ b/dev-ruby/rack/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <longdescription>Rack provides a common API for connecting web frameworks, web servers and layers
+of software inbetween.</longdescription>
+ <upstream>
+ <remote-id type="rubyforge">rack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rack/rack-1.4.6-r1.ebuild b/dev-ruby/rack/rack-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..fcb409470c46
--- /dev/null
+++ b/dev-ruby/rack/rack-1.4.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch ${PN}-1.4.5-fix-test-ruby20.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2 !<dev-ruby/rack-1.3.6-r1:1.3"
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.4.6.ebuild b/dev-ruby/rack/rack-1.4.6.ebuild
new file mode 100644
index 000000000000..f28031fe181c
--- /dev/null
+++ b/dev-ruby/rack/rack-1.4.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch ${PN}-1.4.5-fix-test-ruby20.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2 !<dev-ruby/rack-1.3.6-r1:1.3"
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.5.4-r1.ebuild b/dev-ruby/rack/rack-1.5.4-r1.ebuild
new file mode 100644
index 000000000000..ae35cf81caef
--- /dev/null
+++ b/dev-ruby/rack/rack-1.5.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4"
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.5.4.ebuild b/dev-ruby/rack/rack-1.5.4.ebuild
new file mode 100644
index 000000000000..a7d0b135fe5b
--- /dev/null
+++ b/dev-ruby/rack/rack-1.5.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4"
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.6.2.ebuild b/dev-ruby/rack/rack-1.6.2.ebuild
new file mode 100644
index 000000000000..daf93bb7e15d
--- /dev/null
+++ b/dev-ruby/rack/rack-1.6.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY.md KNOWN-ISSUES README.rdoc SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5"
+
+all_ruby_prepare() {
+ # The build system tries to generate the ChangeLog from git. Create
+ # an empty file to avoid a needless dependency on git.
+ touch ChangeLog || die
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.6.4.ebuild b/dev-ruby/rack/rack-1.6.4.ebuild
new file mode 100644
index 000000000000..daf93bb7e15d
--- /dev/null
+++ b/dev-ruby/rack/rack-1.6.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY.md KNOWN-ISSUES README.rdoc SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5"
+
+all_ruby_prepare() {
+ # The build system tries to generate the ChangeLog from git. Create
+ # an empty file to avoid a needless dependency on git.
+ touch ChangeLog || die
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}