summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/metadata.xml15
-rw-r--r--dev-ruby/thor/thor-0.19.1.ebuild48
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
new file mode 100644
index 000000000000..4948c8bb1c0f
--- /dev/null
+++ b/dev-ruby/thor/Manifest
@@ -0,0 +1 @@
+DIST thor-git-0.19.1.tgz 86389 SHA256 70013a638aa81df39b579cde7c68a1b6418ffa999e596eb89e12cdab14593dff SHA512 67aeaa2822b462c59ea9fd1a197222ce997b0edd30eb714b0a303c816acff82f4fb10a650b8a3c508c796426517ba25a462551fbc73ed7b33d4e16207cad8991 WHIRLPOOL d32b384b06fa338af345f7b13014dbff1bd5aac347437cfc8af8c33e3a14b0054245458e88b1109d769a6e1feb273ec9a7283459cba937bebfa66e8f6653ea05
diff --git a/dev-ruby/thor/metadata.xml b/dev-ruby/thor/metadata.xml
new file mode 100644
index 000000000000..24d60c8be42e
--- /dev/null
+++ b/dev-ruby/thor/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <longdescription>
+ Thor is a simple and efficient tool for building self-documenting
+ command line utilities. It removes the pain of parsing command line
+ options, writing "USAGE:" banners, and can also be used as an
+ alternative to the Rake build tool. The syntax is Rake-like, so it
+ should be familiar to most Rake users.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">erikhuda/thor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/thor/thor-0.19.1.ebuild b/dev-ruby/thor/thor-0.19.1.ebuild
new file mode 100644
index 000000000000..3ffe6813c791
--- /dev/null
+++ b/dev-ruby/thor/thor-0.19.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://whatisthor.com/"
+
+SRC_URI="http://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/fakeweb-1.3
+ dev-ruby/childlabor
+ )"
+
+all_ruby_prepare() {
+ # Remove rspec default options (as we might not have the last
+ # rspec).
+ rm .rspec || die
+
+ # Remove Bundler
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Thorfile || die
+
+ # Remove mandatory coverage collection using simplecov which is not
+ # packaged.
+ sed -i -e '/require .simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+
+ # Avoid a spec that requires UTF-8 support, so LANG=C still works,
+ # bug 430402
+ sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
+}