summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cargo-nextest/cargo-nextest-0.9.88.ebuild')
-rw-r--r--dev-util/cargo-nextest/cargo-nextest-0.9.88.ebuild456
1 files changed, 456 insertions, 0 deletions
diff --git a/dev-util/cargo-nextest/cargo-nextest-0.9.88.ebuild b/dev-util/cargo-nextest/cargo-nextest-0.9.88.ebuild
new file mode 100644
index 000000000000..46941de39105
--- /dev/null
+++ b/dev-util/cargo-nextest/cargo-nextest-0.9.88.ebuild
@@ -0,0 +1,456 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Autogenerated by pycargoebuild 0.6.1
+
+EAPI=8
+
+CRATES="
+ addr2line@0.21.0
+ adler2@2.0.0
+ adler@1.0.2
+ ahash@0.8.11
+ aho-corasick@1.1.3
+ android-tzdata@0.1.1
+ android_system_properties@0.1.5
+ anstream@0.6.17
+ anstyle-parse@0.2.6
+ anstyle-query@1.1.2
+ anstyle-wincon@3.0.6
+ anstyle@1.0.9
+ anyhow@1.0.91
+ async-scoped@0.9.0
+ async-stream-impl@0.3.6
+ async-stream@0.3.6
+ async-trait@0.1.83
+ atomic-waker@1.1.2
+ atomicwrites@0.4.4
+ autocfg@1.4.0
+ axum-core@0.4.5
+ axum@0.7.7
+ backtrace-ext@0.2.1
+ backtrace@0.3.71
+ base64@0.21.7
+ base64@0.22.1
+ base64ct@1.6.0
+ bit-set@0.8.0
+ bit-vec@0.8.0
+ bitflags@2.8.0
+ block-buffer@0.10.4
+ borsh@1.5.1
+ bstr@1.11.3
+ bumpalo@3.16.0
+ byteorder@1.5.0
+ bytes@1.9.0
+ camino-tempfile@1.1.1
+ camino@1.1.9
+ cargo-platform@0.1.9
+ cargo_metadata@0.19.1
+ cc@1.2.5
+ cfg-expr@0.17.2
+ cfg-if@1.0.0
+ cfg_aliases@0.2.1
+ chrono@0.4.39
+ clap@4.5.26
+ clap_builder@4.5.26
+ clap_derive@4.5.24
+ clap_lex@0.7.4
+ color-eyre@0.6.3
+ color-spantrace@0.2.1
+ colorchoice@1.0.3
+ config@0.15.6
+ console-api@0.8.1
+ console-subscriber@0.4.1
+ console@0.15.8
+ const-oid@0.9.6
+ core-foundation-sys@0.8.7
+ core-foundation@0.9.4
+ cp_r@0.5.2
+ cpufeatures@0.2.14
+ crc32fast@1.4.2
+ crossbeam-channel@0.5.13
+ crossbeam-utils@0.8.20
+ crossterm@0.28.1
+ crossterm_winapi@0.9.1
+ crypto-common@0.1.6
+ curve25519-dalek-derive@0.1.1
+ curve25519-dalek@4.1.3
+ datatest-stable@0.3.2
+ debug-ignore@1.0.5
+ der@0.7.9
+ derive-where@1.2.7
+ dialoguer@0.11.0
+ diff@0.1.13
+ digest@0.10.7
+ duct@0.13.7
+ dunce@1.0.5
+ ed25519-dalek@2.1.1
+ ed25519@2.2.3
+ either@1.13.0
+ enable-ansi-support@0.2.1
+ encode_unicode@0.3.6
+ equivalent@1.0.1
+ erased-serde@0.4.5
+ errno@0.3.9
+ escape8259@0.5.3
+ eyre@0.6.12
+ fancy-regex@0.14.0
+ fastrand@2.1.1
+ fiat-crypto@0.2.9
+ filetime@0.2.25
+ fixedbitset@0.4.2
+ flate2@1.0.34
+ fnv@1.0.7
+ foreign-types-shared@0.1.1
+ foreign-types@0.3.2
+ form_urlencoded@1.2.1
+ fs-err@3.0.0
+ future-queue@0.3.0
+ futures-channel@0.3.31
+ futures-core@0.3.31
+ futures-executor@0.3.31
+ futures-io@0.3.31
+ futures-macro@0.3.31
+ futures-sink@0.3.31
+ futures-task@0.3.31
+ futures-util@0.3.31
+ futures@0.3.31
+ generic-array@0.14.7
+ getrandom@0.2.15
+ gimli@0.28.1
+ globset@0.4.15
+ guppy-workspace-hack@0.1.0
+ guppy@0.17.12
+ h2@0.4.6
+ hashbrown@0.12.3
+ hashbrown@0.15.2
+ hdrhistogram@7.5.4
+ heck@0.5.0
+ hex@0.4.3
+ home@0.5.11
+ http-body-util@0.1.2
+ http-body@1.0.1
+ http@1.2.0
+ httparse@1.9.5
+ httpdate@1.0.3
+ humantime-serde@1.1.1
+ humantime@2.1.0
+ hyper-rustls@0.27.3
+ hyper-timeout@0.5.1
+ hyper-tls@0.6.0
+ hyper-util@0.1.9
+ hyper@1.5.0
+ iana-time-zone-haiku@0.1.2
+ iana-time-zone@0.1.61
+ idna@1.0.3
+ idna_adapter@1.0.0
+ include_dir@0.7.4
+ include_dir_macros@0.7.4
+ indent_write@2.2.0
+ indenter@0.3.3
+ indexmap@1.9.3
+ indexmap@2.7.0
+ indicatif@0.17.9
+ indoc@2.0.5
+ insta@1.42.0
+ ipnet@2.10.1
+ is_ci@1.2.0
+ is_terminal_polyfill@1.70.1
+ itertools@0.13.0
+ itertools@0.14.0
+ itoa@1.0.14
+ jobserver@0.1.32
+ js-sys@0.3.72
+ lazy_static@1.5.0
+ libc@0.2.169
+ libredox@0.1.3
+ libtest-mimic@0.8.1
+ linked-hash-map@0.5.6
+ linux-raw-sys@0.4.14
+ lock_api@0.4.12
+ log@0.4.24
+ maplit@1.0.2
+ matchers@0.1.0
+ matchit@0.7.3
+ memchr@2.7.4
+ miette-derive@7.4.0
+ miette@7.4.0
+ mime@0.3.17
+ minimal-lexical@0.2.1
+ miniz_oxide@0.7.4
+ miniz_oxide@0.8.0
+ mio@1.0.3
+ mukti-metadata@0.3.0
+ native-tls@0.2.12
+ nested@0.1.1
+ newtype-uuid@1.2.1
+ nix@0.29.0
+ nom@7.1.3
+ num-traits@0.2.19
+ num_threads@0.1.7
+ number_prefix@0.4.0
+ object@0.32.2
+ once_cell@1.20.2
+ openssl-macros@0.1.1
+ openssl-probe@0.1.5
+ openssl-sys@0.9.104
+ openssl@0.10.68
+ os_pipe@1.2.1
+ owo-colors@3.5.0
+ owo-colors@4.1.0
+ parking_lot@0.12.3
+ parking_lot_core@0.9.10
+ pathdiff@0.2.3
+ percent-encoding@2.3.1
+ petgraph@0.6.5
+ pin-project-internal@1.1.7
+ pin-project-lite@0.2.16
+ pin-project@1.1.7
+ pin-utils@0.1.0
+ pkcs8@0.10.2
+ pkg-config@0.3.31
+ portable-atomic@1.9.0
+ ppv-lite86@0.2.20
+ pretty_assertions@1.4.1
+ proc-macro2@1.0.93
+ proptest@1.6.0
+ prost-derive@0.13.3
+ prost-types@0.13.3
+ prost@0.13.3
+ quick-error@1.2.3
+ quick-junit@0.5.1
+ quick-xml@0.23.1
+ quick-xml@0.37.1
+ quinn-proto@0.11.8
+ quinn-udp@0.5.5
+ quinn@0.11.5
+ quote@1.0.38
+ rand@0.8.5
+ rand_chacha@0.3.1
+ rand_core@0.6.4
+ rand_xorshift@0.3.0
+ recursion@0.5.2
+ redox_syscall@0.5.7
+ regex-automata@0.1.10
+ regex-automata@0.4.8
+ regex-syntax@0.6.29
+ regex-syntax@0.8.5
+ regex@1.11.1
+ reqwest@0.12.8
+ ring@0.17.8
+ ron@0.8.1
+ rustc-demangle@0.1.24
+ rustc-hash@2.0.0
+ rustc_version@0.4.1
+ rustix@0.38.37
+ rustls-pemfile@2.2.0
+ rustls-pki-types@1.10.0
+ rustls-webpki@0.102.8
+ rustls@0.23.19
+ rustversion@1.0.18
+ rusty-fork@0.3.0
+ ryu@1.0.18
+ same-file@1.0.6
+ schannel@0.1.26
+ scopeguard@1.2.0
+ security-framework-sys@2.12.0
+ security-framework@2.11.1
+ self-replace@1.5.0
+ self_update@0.41.0
+ semver@1.0.24
+ serde@1.0.217
+ serde_derive@1.0.217
+ serde_fmt@1.0.3
+ serde_ignored@0.1.10
+ serde_json@1.0.135
+ serde_path_to_error@0.1.16
+ serde_spanned@0.6.8
+ serde_urlencoded@0.7.1
+ sha2@0.10.8
+ sharded-slab@0.1.7
+ shared_child@1.0.1
+ shell-words@1.1.0
+ shlex@1.3.0
+ signal-hook-mio@0.2.4
+ signal-hook-registry@1.4.2
+ signal-hook@0.3.17
+ signature@2.2.0
+ similar@2.6.0
+ slab@0.4.9
+ smallvec@1.13.2
+ smol_str@0.3.2
+ socket2@0.5.8
+ spin@0.9.8
+ spki@0.7.3
+ static_assertions@1.1.0
+ strip-ansi-escapes@0.2.1
+ strsim@0.11.1
+ structmeta-derive@0.3.0
+ structmeta@0.3.0
+ subtle@2.6.1
+ supports-color@3.0.2
+ supports-hyperlinks@3.0.0
+ supports-unicode@3.0.0
+ sval@2.13.2
+ sval_buffer@2.13.2
+ sval_dynamic@2.13.2
+ sval_fmt@2.13.2
+ sval_json@2.13.2
+ sval_nested@2.13.2
+ sval_ref@2.13.2
+ sval_serde@2.13.2
+ swrite@0.1.0
+ syn@2.0.96
+ sync_wrapper@0.1.2
+ sync_wrapper@1.0.1
+ tar@0.4.43
+ target-lexicon@0.12.16
+ target-spec-miette@0.4.4
+ target-spec@3.3.1
+ tempfile@3.13.0
+ terminal_size@0.4.0
+ test-case-core@3.3.1
+ test-case-macros@3.3.1
+ test-case@3.3.1
+ test-strategy@0.4.0
+ textwrap@0.16.1
+ thiserror-impl@1.0.69
+ thiserror-impl@2.0.11
+ thiserror@1.0.69
+ thiserror@2.0.11
+ thread_local@1.1.8
+ tinyvec@1.8.0
+ tinyvec_macros@0.1.1
+ tokio-macros@2.5.0
+ tokio-native-tls@0.3.1
+ tokio-rustls@0.26.0
+ tokio-stream@0.1.17
+ tokio-util@0.7.12
+ tokio@1.43.0
+ toml@0.8.19
+ toml_datetime@0.6.8
+ toml_edit@0.22.22
+ tonic@0.12.3
+ tower-layer@0.3.3
+ tower-service@0.3.3
+ tower@0.4.13
+ tower@0.5.1
+ tracing-attributes@0.1.28
+ tracing-core@0.1.33
+ tracing-error@0.2.0
+ tracing-log@0.2.0
+ tracing-subscriber@0.3.19
+ tracing@0.1.41
+ try-lock@0.2.5
+ typeid@1.0.2
+ typenum@1.17.0
+ unarray@0.1.4
+ unicase@2.8.0
+ unicode-ident@1.0.14
+ unicode-linebreak@0.1.5
+ unicode-normalization@0.1.24
+ unicode-width@0.1.14
+ unicode-width@0.2.0
+ untrusted@0.9.0
+ url@2.5.4
+ urlencoding@2.1.3
+ utf8_iter@1.0.4
+ utf8parse@0.2.2
+ uuid@1.11.0
+ valuable@0.1.0
+ value-bag-serde1@1.10.0
+ value-bag-sval2@1.10.0
+ value-bag@1.10.0
+ vcpkg@0.2.15
+ version_check@0.9.5
+ vte@0.14.1
+ wait-timeout@0.2.0
+ walkdir@2.5.0
+ want@0.3.1
+ wasi@0.11.0+wasi-snapshot-preview1
+ wasite@0.1.0
+ wasm-bindgen-backend@0.2.95
+ wasm-bindgen-futures@0.4.45
+ wasm-bindgen-macro-support@0.2.95
+ wasm-bindgen-macro@0.2.95
+ wasm-bindgen-shared@0.2.95
+ wasm-bindgen@0.2.95
+ web-sys@0.3.72
+ web-time@1.1.0
+ webpki-roots@0.26.6
+ whoami@1.5.2
+ win32job@2.0.0
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-util@0.1.9
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ winapi@0.3.9
+ windows-core@0.52.0
+ windows-registry@0.2.0
+ windows-result@0.2.0
+ windows-strings@0.1.0
+ windows-sys@0.42.0
+ windows-sys@0.52.0
+ windows-sys@0.59.0
+ windows-targets@0.52.6
+ windows@0.52.0
+ windows_aarch64_gnullvm@0.42.2
+ windows_aarch64_gnullvm@0.52.6
+ windows_aarch64_msvc@0.42.2
+ windows_aarch64_msvc@0.52.6
+ windows_i686_gnu@0.42.2
+ windows_i686_gnu@0.52.6
+ windows_i686_gnullvm@0.52.6
+ windows_i686_msvc@0.42.2
+ windows_i686_msvc@0.52.6
+ windows_x86_64_gnu@0.42.2
+ windows_x86_64_gnu@0.52.6
+ windows_x86_64_gnullvm@0.42.2
+ windows_x86_64_gnullvm@0.52.6
+ windows_x86_64_msvc@0.42.2
+ windows_x86_64_msvc@0.52.6
+ winnow@0.6.24
+ xattr@1.3.1
+ xxhash-rust@0.8.15
+ yansi@1.0.1
+ zerocopy-derive@0.7.35
+ zerocopy@0.7.35
+ zeroize@1.8.1
+ zipsign-api@0.1.2
+ zstd-safe@7.2.1
+ zstd-sys@2.0.13+zstd.1.5.6
+ zstd@0.13.2
+"
+
+RUST_MIN_VER="1.81"
+
+inherit cargo
+
+DESCRIPTION="Next-generation test runner for Rust"
+HOMEPAGE="https://nexte.st/"
+SRC_URI=" https://github.com/nextest-rs/nextest/archive/refs/tags/${P}.tar.gz"
+SRC_URI+=" ${CARGO_CRATE_URIS}"
+S="${WORKDIR}"/nextest-${P}/${PN}
+
+LICENSE="|| ( Apache-2.0 MIT )"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 ISC MIT
+ MPL-2.0 Unicode-3.0
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ >=app-arch/zstd-1.5.5:=
+ dev-libs/openssl
+"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED="usr/bin/cargo-nextest"
+
+pkg_setup() {
+ export OPENSSL_NO_VENDOR=1
+ export ZSTD_SYS_USE_PKG_CONFIG=1
+ rust_pkg_setup
+}