summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libraw/libraw-0.21.2.ebuild')
-rw-r--r--media-libs/libraw/libraw-0.21.2.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/media-libs/libraw/libraw-0.21.2.ebuild b/media-libs/libraw/libraw-0.21.2.ebuild
index 500650195963..b45f1cb997a4 100644
--- a/media-libs/libraw/libraw-0.21.2.ebuild
+++ b/media-libs/libraw/libraw-0.21.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal toolchain-funcs
+inherit flag-o-matic multilib-minimal toolchain-funcs
MY_PN=LibRaw
MY_PV="${PV/_b/-B}"
@@ -12,6 +12,7 @@ MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
HOMEPAGE="https://www.libraw.org/ https://github.com/LibRaw/LibRaw"
SRC_URI="https://www.libraw.org/data/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1 CDDL"
# SONAME isn't exactly the same as PV but it does correspond and
@@ -28,8 +29,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
-
DOCS=( Changelog.txt README.md )
pkg_pretend() {
@@ -40,6 +39,14 @@ pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
+src_prepare() {
+ default
+
+ if tc-is-clang && use openmp ; then
+ append-libs omp
+ fi
+}
+
multilib_src_configure() {
local myeconfargs=(
--disable-jasper