summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/a2jmidid/a2jmidid-9.ebuild')
-rw-r--r--media-sound/a2jmidid/a2jmidid-9.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/media-sound/a2jmidid/a2jmidid-9.ebuild b/media-sound/a2jmidid/a2jmidid-9.ebuild
index 62228ef8c0d6..1d5c181d312a 100644
--- a/media-sound/a2jmidid/a2jmidid-9.ebuild
+++ b/media-sound/a2jmidid/a2jmidid-9.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+PYTHON_COMPAT=( python3_{6..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson python-single-r1
DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
@@ -12,7 +15,8 @@ SRC_URI="https://github.com/linuxaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="dbus"
+IUSE="dbus python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
virtual/pkgconfig
@@ -21,6 +25,7 @@ CDEPEND="
media-libs/alsa-lib
virtual/jack
dbus? ( sys-apps/dbus )
+ python? ( ${PYTHON_DEPS} )
"
RDEPEND="${CDEPEND}"
DEPEND="${RDEPEND}"
@@ -34,3 +39,13 @@ src_configure() {
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ if use python; then
+ python_fix_shebang "${ED}"
+ else
+ rm "${ED}/usr/bin/a2j_control" || die
+ fi
+}