summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-2.44.4-r600.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.44.4-r600.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.44.4-r600.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.44.4-r600.ebuild
index 1e00c03e2eec..ddfabfb6e1b6 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.44.4-r600.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.44.4-r600.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -161,6 +161,9 @@ src_prepare() {
# https://bugs.gentoo.org/943213
eapply "${FILESDIR}"/2.44.4-fix-icu76.1.patch
+
+ # We don't want -Werror for gobject-introspection (bug #947761)
+ sed -i -e "s:--warn-error::" Source/cmake/FindGI.cmake || die
}
src_configure() {
@@ -170,6 +173,11 @@ src_configure() {
# ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
filter-lto
+ # bug #948072 (gcc PR118464)
+ if tc-is-gcc && [[ $(gcc-major-version) -eq 15 ]]; then
+ append-cxxflags "-fno-tree-loop-optimize"
+ fi
+
# It does not compile on alpha without this in LDFLAGS
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"