summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/altermime/altermime-0.3.7.ebuild')
-rw-r--r--net-mail/altermime/altermime-0.3.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-mail/altermime/altermime-0.3.7.ebuild b/net-mail/altermime/altermime-0.3.7.ebuild
new file mode 100644
index 000000000000..846ec0d219bd
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
+HOMEPAGE="http://pldaniels.com/altermime/"
+
+LICENSE="Sendmail"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "/^CFLAGS[[:space:]]*=/ s/-O2/${CFLAGS}/" \
+ -e 's/${CFLAGS} altermime.c/${CFLAGS} ${LDFLAGS} altermime.c/' \
+ "${S}"/Makefile || die "sed failed."
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install () {
+ dobin altermime || die "dobin failed."
+ dodoc CHANGELOG LICENCE README || die "dodoc failed."
+}