summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild')
-rw-r--r--sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild b/sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild
new file mode 100644
index 000000000000..d6a7520cbad7
--- /dev/null
+++ b/sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python 3-D coordinate conversions"
+HOMEPAGE="https://github.com/geospace-code/pymap3d"
+SRC_URI="https://github.com/geospace-code/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="test? (
+ dev-python/xarray
+ dev-python/pyproj
+)"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm src/pymap3d/tests/test_eci.py || die
+ default
+}