summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild')
-rw-r--r--sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild b/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
new file mode 100644
index 000000000000..23422f9cc125
--- /dev/null
+++ b/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+CommitId=bb1473a4b38b18268e8693044afdb8635bc8351b
+
+DESCRIPTION="provides a tensor-aware channel"
+HOMEPAGE="https://github.com/pytorch/tensorpipe/"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT=test
+
+RDEPEND="
+ dev-libs/libuv
+"
+DEPEND="${RDEPEND}
+ dev-libs/libnop
+"
+BDEPEND=""
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )