summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 55c4ac98da38..8ab713955c87 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -203,7 +203,7 @@ multilib_src_configure() {
-Dbashcompletiondir="$(get_bashcompdir)"
# make sure we get /bin:/sbin in $PATH
-Dsplit-usr=true
- -Drootprefix="${ROOTPREFIX}"
+ -Drootprefix="${EPREFIX}${ROOTPREFIX}"
-Dsysvinit-path=
-Dsysvrcnd-path=
# no deps
@@ -326,6 +326,12 @@ multilib_src_install_all() {
rm -r "${ED%/}"/etc/systemd/system/sysinit.target.wants || die
rm -r "${ED%/}${ROOTPREFIX%/}/lib/udev/hwdb.d" || die
+
+ if [[ ! -e "${ED%/}"/usr/lib/systemd/systemd ]]; then
+ # Avoid breaking boot/reboot
+ dosym "../../..${ROOTPREFIX%/}/lib/systemd/systemd" /usr/lib/systemd/systemd
+ dosym "../../..${ROOTPREFIX%/}/lib/systemd/systemd-shutdown" /usr/lib/systemd/systemd-shutdown
+ fi
}
migrate_locale() {