summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/tboot')
-rw-r--r--sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch12
-rw-r--r--sys-boot/tboot/tboot-1.10.3.ebuild5
2 files changed, 15 insertions, 2 deletions
diff --git a/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch b/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch
new file mode 100644
index 000000000000..83adeda6d5ac
--- /dev/null
+++ b/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch
@@ -0,0 +1,12 @@
+diff -r 5a30b6b09e77 tboot/Makefile
+--- a/tboot/Makefile Fri Dec 10 15:35:42 2021 +0100
++++ b/tboot/Makefile Mon Dec 20 13:06:09 2021 -0600
+@@ -34,7 +34,7 @@
+ TARGET_LDS := $(CURDIR)/common/tboot.lds
+
+ $(TARGET).strip : $(TARGET)
+- strip $< -o $@
++ $(STRIP) $< -o $@
+
+ $(TARGET).gz : $(TARGET).strip
+ gzip -n -f -9 < $< > $@
diff --git a/sys-boot/tboot/tboot-1.10.3.ebuild b/sys-boot/tboot/tboot-1.10.3.ebuild
index 82f0b645458c..1c4693a6e37b 100644
--- a/sys-boot/tboot/tboot-1.10.3.ebuild
+++ b/sys-boot/tboot/tboot-1.10.3.ebuild
@@ -25,10 +25,11 @@ RDEPEND="${DEPEND}
DOCS=( README.md COPYING CHANGELOG )
PATCHES=( "${FILESDIR}/${PN}-1.10.3-disable-Werror.patch"
- "${FILESDIR}/${PN}-1.10.3-disable-strip.patch" )
+ "${FILESDIR}/${PN}-1.10.3-disable-strip.patch"
+ "${FILESDIR}/${PN}-1.10.3-dont-call-strip-directly.patch" )
src_configure() {
- tc-export AS LD CC CPP AR RANLIB NM OBJCOPY OBJDUMP
+ tc-export AS LD CC CPP AR RANLIB NM OBJCOPY OBJDUMP STRIP
default
}