summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.3-r1.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.4.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild b/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild
index 0d894d8b4232..358dca01c333 100644
--- a/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild b/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild b/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF