summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/gitea/gitea-9999.ebuild')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index 672af6461ca6..b92bde68e9a3 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -39,6 +39,9 @@ FILECAPS=(
cap_net_bind_service+ep usr/bin/gitea
)
+RESTRICT="test"
+QA_PRESTRIPPED="usr/bin/gitea"
+
src_prepare() {
default
@@ -114,3 +117,9 @@ src_install() {
keepdir /var/log/gitea
fi
}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ go-module_pkg_postinst
+ tmpfiles_process gitea.conf
+}