summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author <jerrya@gentoo.org>2001-12-09 23:47:08 +0000
committer <jerrya@gentoo.org>2001-12-09 23:47:08 +0000
commit03db62d9011719b5e10064d3682461ef87601ae6 (patch)
tree6c845bc2eeda7bfb9d9dc7df07f135fa74673fd1
parentupdated (diff)
downloadhistorical-03db62d9011719b5e10064d3682461ef87601ae6.tar.gz
historical-03db62d9011719b5e10064d3682461ef87601ae6.tar.bz2
historical-03db62d9011719b5e10064d3682461ef87601ae6.zip
Scratch another one out of incoming.
Thanks to Michael Nazaroff <naz@themoonsofjupiter.net> for his contribution. Previous version moved to the Attic.
-rw-r--r--incoming/bind-tools-9.1.3.ebuild40
-rw-r--r--net-misc/bind-tools/bind-tools-9.1.3-r1.ebuild43
-rw-r--r--net-misc/bind-tools/bind-tools-9.1.3.ebuild43
-rw-r--r--net-misc/bind-tools/files/digest-bind-tools-9.1.31
-rw-r--r--net-misc/bind-tools/files/digest-bind-tools-9.1.3-r11
5 files changed, 44 insertions, 84 deletions
diff --git a/incoming/bind-tools-9.1.3.ebuild b/incoming/bind-tools-9.1.3.ebuild
deleted file mode 100644
index 1fd14c63ea2c..000000000000
--- a/incoming/bind-tools-9.1.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Michael Nazaroff <naz@themoonsofjupiter.net>
-# /home/cvsroot/gentoo-x86/net-misc/bind-tools/bind-tools-9.1.3.ebuild,v 1
-
-A=bind-9.1.3.tar.gz
-S=${WORKDIR}/bind-9.1.3
-DESCRIPTION="bind tools: dig, nslookup, and host"
-SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${A}"
-
-DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${A}
-
-}
-
-src_compile() {
-
- cd ${S}
- ./configure --host=${CHOST} || die
- cd ${S}/lib/isc
- make || die
- cd ${S}/lib/dns
- make || die
- cd ${S}/bin/dig
- make || die
-}
-
-src_install() {
- insinto /usr
- dobin ${S}/bin/dig/dig
- dobin ${S}/bin/dig/nslookup
- dobin ${S}/bin/dig/host
- doman ${S}/doc/man/bin/dig.1
- doman ${S}/doc/man/bin/host.1
- dodoc README CHANGES FAQ COPYRIGHT
-
-}
diff --git a/net-misc/bind-tools/bind-tools-9.1.3-r1.ebuild b/net-misc/bind-tools/bind-tools-9.1.3-r1.ebuild
new file mode 100644
index 000000000000..896fb66e8b0e
--- /dev/null
+++ b/net-misc/bind-tools/bind-tools-9.1.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Jerry A! <jerry@thehutt.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bind-tools/bind-tools-9.1.3-r1.ebuild,v 1.1 2001/12/09 23:47:08 jerrya Exp $
+
+S=${WORKDIR}/bind-9.1.3
+DESCRIPTION="bind tools: dig, nslookup, and host"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P//-tools}.tar.gz"
+HOMEPAGE="http://www.isc.org/BIND/bind9.html"
+
+DEPEND="virtual/glibc"
+
+
+src_unpack() {
+ unpack ${P//-tools}.tar.gz
+
+}
+
+src_compile() {
+ ./configure --host=${CHOST} || die
+
+ cd ${S}/lib/isc
+ make || die
+
+ cd ${S}/lib/dns
+ make || die
+
+ cd ${S}/bin/dig
+ make || die
+}
+
+src_install() {
+ cd ${S}/bin/dig
+ dobin dig host nslookup
+
+ cd ${S}/doc/man/bin
+ doman dig.1 host.1
+
+ doman ${FILESDIR}/nslookup.8
+
+ cd ${S}
+ dodoc README CHANGES FAQ COPYRIGHT
+}
diff --git a/net-misc/bind-tools/bind-tools-9.1.3.ebuild b/net-misc/bind-tools/bind-tools-9.1.3.ebuild
deleted file mode 100644
index 9c1bc3e46136..000000000000
--- a/net-misc/bind-tools/bind-tools-9.1.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Donny Davies <woodchip@gentoo.org>, Michael Nazaroff <naz@themoonsofjupiter.net>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bind-tools/bind-tools-9.1.3.ebuild,v 1.1 2001/11/20 05:17:24 woodchip Exp $
-
-P=bind-${PV}
-S=${WORKDIR}/${P}
-DESCRIPTION="DNS querying tools from BIND: dig, host, and nslookup"
-HOMEPAGE="http://www.isc.org/products/BIND/"
-SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz"
-
-DEPEND="virtual/glibc sys-devel/perl ssl? ( >=dev-libs/openssl-0.9.6 )"
-RDEPEND="virtual/glibc"
-
-src_compile() {
-
- # We just want host, dig and nslookup. Nslookup is deprecated for dig
- # but its still around. Adding -static to CFLAGS results in the
- # programs being built with the libdns and libisc stuff statically.
- # They're still dynamically linked with glibc. Hopefully this avoids
- # any possible conflicts or problems with those libs being installed.
-
- local myconf
- use ssl && myconf="--with-openssl=/usr"
-
- export CFLAGS="${CFLAGS} -static"
-
- ./configure \
- --with-libtool \
- --host=${CHOST} ${myconf} || die "bad configure"
-
- make depend || die "couldnt make depend"
- make -C lib/dns || die "problem in lib/dns"
- make -C lib/isc || die "problem in lib/isc"
- make -C bin/dig || die "problem in bin/dig"
-}
-
-src_install() {
-
- dobin bin/dig/{dig,host,nslookup}
- doman doc/man/bin/{dig,host}.1 ${FILESDIR}/nslookup.8
- dodoc README CHANGES FAQ COPYRIGHT
-}
diff --git a/net-misc/bind-tools/files/digest-bind-tools-9.1.3 b/net-misc/bind-tools/files/digest-bind-tools-9.1.3
deleted file mode 100644
index 4a1ba949f263..000000000000
--- a/net-misc/bind-tools/files/digest-bind-tools-9.1.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1d52f78d5d0d38b7687543d79f0cf4c2 bind-9.1.3.tar.gz 3317760
diff --git a/net-misc/bind-tools/files/digest-bind-tools-9.1.3-r1 b/net-misc/bind-tools/files/digest-bind-tools-9.1.3-r1
new file mode 100644
index 000000000000..15933bf8b11e
--- /dev/null
+++ b/net-misc/bind-tools/files/digest-bind-tools-9.1.3-r1
@@ -0,0 +1 @@
+MD5 1d52f78d5d0d38b7687543d79f0cf4c2 bind-9.1.3.tar.gz 3321856