summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-29 10:32:24 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-29 10:32:24 +0000
commit0a0603765fcd451a47b234f1275dafb91cfdd839 (patch)
tree6addd37ee1c203add1e21c43d55939c2de0a8bbd
parentnew version (diff)
downloadhistorical-0a0603765fcd451a47b234f1275dafb91cfdd839.tar.gz
historical-0a0603765fcd451a47b234f1275dafb91cfdd839.tar.bz2
historical-0a0603765fcd451a47b234f1275dafb91cfdd839.zip
fix for -Os; bug #12775
-rw-r--r--x11-base/xfree/ChangeLog6
-rw-r--r--x11-base/xfree/xfree-4.2.1-r2.ebuild13
-rw-r--r--x11-base/xfree/xfree-4.2.99.3-r1.ebuild13
3 files changed, 19 insertions, 13 deletions
diff --git a/x11-base/xfree/ChangeLog b/x11-base/xfree/ChangeLog
index 10ac47809503..ff5f16572c84 100644
--- a/x11-base/xfree/ChangeLog
+++ b/x11-base/xfree/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-base/xfree
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/ChangeLog,v 1.79 2002/12/26 20:05:07 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/ChangeLog,v 1.80 2002/12/29 10:32:24 azarah Exp $
+
+ 28 Dec 2002; Martin Schlemmer <azarah@gentoo.org> xfree-4.2.1-r2.ebuild :
+
+ XFree86 do not like CFLAGS="-Os", filter for this, bug #12775.
26 Dec 2002; Martin Schlemmer <azarah@gentoo.org> xfree-4.2.1-r2.ebuild :
diff --git a/x11-base/xfree/xfree-4.2.1-r2.ebuild b/x11-base/xfree/xfree-4.2.1-r2.ebuild
index 07761ab6dc21..4b9753ca8fae 100644
--- a/x11-base/xfree/xfree-4.2.1-r2.ebuild
+++ b/x11-base/xfree/xfree-4.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/xfree-4.2.1-r2.ebuild,v 1.11 2002/12/26 20:05:07 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/xfree-4.2.1-r2.ebuild,v 1.12 2002/12/29 10:32:24 azarah Exp $
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
@@ -219,14 +219,15 @@ src_unpack() {
echo "#define XVendorString \"Gentoo Linux (XFree86 ${PV}, revision ${PR})\"" \
>> config/cf/host.def
+ # Bug #12775 .. fails with -Os.
+ replace-flags "-Os" "-O2"
+
if [ "`gcc-version`" != "2.95" ]
then
- # should fix bug #4189. gcc-3.x have problems with -march=pentium4
+ # Should fix bug #4189. gcc-3.x have problems with -march=pentium4
# and -march=athlon-tbird
- export CFLAGS="${CFLAGS/-march=pentium4/-march=pentium3}"
- export CXXFLAGS="${CXXFLAGS/-march=pentium4/-march=pentium3}"
- export CFLAGS="${CFLAGS/-march=athlon-tbird/-march=athlon}"
- export CXXFLAGS="${CXXFLAGS/-march=athlon-tbird/-march=athlon}"
+ replace-flags "-march=pentium4" "-march=pentium3"
+ replace-flags "-march=athlon-tbird" "-march=athlon"
# Without this, modules breaks with gcc3
if [ "`gcc-version`" = "3.1" ]
diff --git a/x11-base/xfree/xfree-4.2.99.3-r1.ebuild b/x11-base/xfree/xfree-4.2.99.3-r1.ebuild
index 6af053c69305..0ea912ff0b66 100644
--- a/x11-base/xfree/xfree-4.2.99.3-r1.ebuild
+++ b/x11-base/xfree/xfree-4.2.99.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/xfree-4.2.99.3-r1.ebuild,v 1.4 2002/12/24 18:44:25 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/xfree-4.2.99.3-r1.ebuild,v 1.5 2002/12/29 10:32:24 azarah Exp $
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
@@ -211,14 +211,15 @@ src_unpack() {
echo "#define XVendorString \"Gentoo Linux (XFree86 ${PV}, revision ${PR})\"" \
>> config/cf/host.def
+ # Bug #12775 .. fails with -Os.
+ replace-flags "-Os" "-O2"
+
if [ "`gcc-version`" != "2.95" ]
then
- # should fix bug #4189. gcc-3.x have problems with -march=pentium4
+ # Should fix bug #4189. gcc-3.x have problems with -march=pentium4
# and -march=athlon-tbird
- export CFLAGS="${CFLAGS/-march=pentium4/-march=pentium3}"
- export CXXFLAGS="${CXXFLAGS/-march=pentium4/-march=pentium3}"
- export CFLAGS="${CFLAGS/-march=athlon-tbird/-march=athlon}"
- export CXXFLAGS="${CXXFLAGS/-march=athlon-tbird/-march=athlon}"
+ replace-flags "-march=pentium4" "-march=pentium3"
+ replace-flags "-march=athlon-tbird" "-march=athlon"
# Without this, modules breaks with gcc3
if [ "`gcc-version`" = "3.1" ]