summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-25 15:56:29 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-25 15:56:29 +0000
commit1c86c002bcdca99ae818d263a75f7a8cbe2d892b (patch)
treec951ddf565821eb2ccea685f6751a849fa281bed
parentoops (diff)
downloadhistorical-1c86c002bcdca99ae818d263a75f7a8cbe2d892b.tar.gz
historical-1c86c002bcdca99ae818d263a75f7a8cbe2d892b.tar.bz2
historical-1c86c002bcdca99ae818d263a75f7a8cbe2d892b.zip
James Henstridge's GTK bindings for Python
-rw-r--r--dev-python/pygtk/files/digest-pygtk-0.6.81
-rw-r--r--dev-python/pygtk/pygtk-0.6.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pygtk/files/digest-pygtk-0.6.8 b/dev-python/pygtk/files/digest-pygtk-0.6.8
new file mode 100644
index 000000000000..9f4a5711d86a
--- /dev/null
+++ b/dev-python/pygtk/files/digest-pygtk-0.6.8
@@ -0,0 +1 @@
+MD5 4a1014123fb0d7fec96a6ae370e17240 pygtk-0.6.8.tar.gz
diff --git a/dev-python/pygtk/pygtk-0.6.8.ebuild b/dev-python/pygtk/pygtk-0.6.8.ebuild
new file mode 100644
index 000000000000..77b0c6712462
--- /dev/null
+++ b/dev-python/pygtk/pygtk-0.6.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.8.ebuild,v 1.1 2001/09/25 15:56:29 karltk Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ bindings for Python"
+
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/pygtk-0.6.8.tar.gz"
+
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+
+DEPEND="virtual/python
+ >=gnome-base/libglade-0.16
+ >=x11-libs/gtk+-1.2.8"
+
+src_compile() {
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --with-libglade-config=/opt/gnome/bin/libglade-config \
+ --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+# make DESTDIR=${D} install || die
+}
+