summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-05-08 18:31:28 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-05-08 18:31:28 +0000
commit2a58b43696a86a3c8f17a6fe1c6cc85b9533af00 (patch)
treebc624fe11e7bd381fe07a001d8e46e2bbd67e426
parentStable on amd64 wrt bug #414241 (diff)
downloadhistorical-2a58b43696a86a3c8f17a6fe1c6cc85b9533af00.tar.gz
historical-2a58b43696a86a3c8f17a6fe1c6cc85b9533af00.tar.bz2
historical-2a58b43696a86a3c8f17a6fe1c6cc85b9533af00.zip
New ebuild by Martin Väth
Package-Manager: portage-2.1.10.56/cvs/Linux x86_64
-rw-r--r--app-shells/push/ChangeLog10
-rw-r--r--app-shells/push/Manifest4
-rw-r--r--app-shells/push/metadata.xml21
-rw-r--r--app-shells/push/push-1.5.ebuild21
4 files changed, 56 insertions, 0 deletions
diff --git a/app-shells/push/ChangeLog b/app-shells/push/ChangeLog
new file mode 100644
index 000000000000..a4297acb397a
--- /dev/null
+++ b/app-shells/push/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-shells/push
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/push/ChangeLog,v 1.1 2012/05/08 18:31:28 darkside Exp $
+
+*push-1.5 (08 May 2012)
+
+ 08 May 2012; Jeremy Olexa <darkside@gentoo.org> +push-1.5.ebuild,
+ +metadata.xml:
+ New ebuild by Martin Väth
+
diff --git a/app-shells/push/Manifest b/app-shells/push/Manifest
new file mode 100644
index 000000000000..ea6dbac9fac7
--- /dev/null
+++ b/app-shells/push/Manifest
@@ -0,0 +1,4 @@
+DIST push-1.5.tar.gz 1971 RMD160 262ae766077ab2e290a43256d390ce48731655ba SHA1 90bcf19e8870c4b38dcaf5c1f6f36d02f6b0d38a SHA256 7c9068a619bcc49e3e13f819e23e1c05464729df0529753557f23f65e922fdad
+EBUILD push-1.5.ebuild 724 RMD160 d14b0827dd58b8d3909a35b4a00640477e56d843 SHA1 02ce288a4b3758be25a97aa203c377c5152e8e58 SHA256 0155eab7348bcf584e4bf1790dadb44373116c6f7a2992f9678376dc3912248e
+MISC ChangeLog 345 RMD160 2863944002108aba6d43adae746b82f7d40965f4 SHA1 371bd6e057030e7e7905f28c8472670caa77a86a SHA256 156a9c2f94262163f061864ae93651d40b3af38bda768614d0fd493cbe391fd1
+MISC metadata.xml 676 RMD160 0cfe595d05b12eb92658a6bef3e4ab9534969db0 SHA1 173c9fa2be87a2fce8a998a642da4958df43c960 SHA256 8f98eee1ac053d07128e7d6d1da2cd4b2e826b87d52719d19e498d2a1f041fe0
diff --git a/app-shells/push/metadata.xml b/app-shells/push/metadata.xml
new file mode 100644
index 000000000000..63a32b512488
--- /dev/null
+++ b/app-shells/push/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vaeth@mathematik.uni-wuerzburg.de</email>
+ <name>Martin Väth</name>
+ <description>Upstream developer, assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>darkside@gentoo.org</email>
+ <name>Jeremy Olexa</name>
+ <description>Proxy committer, CC bugs</description>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>vaeth@mathematik.uni-wuerzburg.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:vaeth@mathematik.uni-wuerzburg.de</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/push/push-1.5.ebuild b/app-shells/push/push-1.5.ebuild
new file mode 100644
index 000000000000..0fd10914e9f6
--- /dev/null
+++ b/app-shells/push/push-1.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args."
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/bin
+ doins push.sh
+ dodoc README
+}