summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-08 11:14:40 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-08 11:14:40 +0000
commit40d4f4c091a41f586c648a6764070e07b62a324e (patch)
treea5bc544adcd842605a023bd212738678961f5ab6
parentUpdate ethereal to 0.9.0 (diff)
downloadhistorical-40d4f4c091a41f586c648a6764070e07b62a324e.tar.gz
historical-40d4f4c091a41f586c648a6764070e07b62a324e.tar.bz2
historical-40d4f4c091a41f586c648a6764070e07b62a324e.zip
update to snort 1.8.3
-rw-r--r--net-misc/snort/files/digest-snort-1.8.31
-rw-r--r--net-misc/snort/snort-1.8.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/snort/files/digest-snort-1.8.3 b/net-misc/snort/files/digest-snort-1.8.3
new file mode 100644
index 000000000000..6a7960197d06
--- /dev/null
+++ b/net-misc/snort/files/digest-snort-1.8.3
@@ -0,0 +1 @@
+MD5 21ea22cae02d639b21f8082b47cad27a snort-1.8.3.tar.gz 1708032
diff --git a/net-misc/snort/snort-1.8.3.ebuild b/net-misc/snort/snort-1.8.3.ebuild
new file mode 100644
index 000000000000..71ced5d6c030
--- /dev/null
+++ b/net-misc/snort/snort-1.8.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger achim@gentoo.org
+# $Header: /var/cvsroot/gentoo-x86/net-misc/snort/snort-1.8.3.ebuild,v 1.1 2002/01/08 11:14:40 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Libpcap packet sniffer/logger/lightweight IDS"
+SRC_URI="http://www.snort.org/releases/${P}.tar.gz"
+HOMEPAGE="http://www.snort.org"
+
+DEPEND="virtual/glibc >=net-libs/libpcap-0.5.2
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+RDEPEND="virtual/glibc sys-devel/perl
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_compile() {
+
+ local myconf
+ if [ `use mysql` ]
+ then
+ myconf="--with-mysql-includes=/usr/include/mysql \
+ --with-mysql-libraries=/usr/lib/mysql"
+ else
+ myconf="--without-mysql"
+ fi
+ if [ `use ssl` ]
+ then
+ myconf="$myconf --with-openssl"
+ else
+ myconf="$myconf --without-openssl"
+ fi
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-smbalerts \
+ --enable-pthreads \
+ --without-odbc \
+ --without-postgresql \
+ --without-oracle \
+ $myconf || die
+
+ make || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ insinto /usr/lib/snort/bin
+
+ doins contrib/create_mysql contrib/*.pl contrib/snortlog
+ dodoc AUTHORS BUGS ChangeLog COPYING CREDITS NEWS README.*
+ dodoc RULES.SAMPLE USAGE contrib/pgsql.php3
+
+ insinto /etc/snort
+ doins ${FILESDIR}/snort.conf
+
+ insinto /usr/lib/snort
+ doins *lib
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/snort
+ insinfo /etc/conf.d
+ newins ${FILESDIR}/snort.confd snort
+}
+
+pkg_postint() {
+
+ groupadd snort
+ useradd -s /dev/null -g snort -s /bin/false snort
+}
+