summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-09-13 07:29:55 +0000
committerNed Ludd <solar@gentoo.org>2004-09-13 07:29:55 +0000
commit7468dd65ca55da1a9b319486f5133aa13db4f5c0 (patch)
tree90530dfe8ea2e7b509bc2379270a794bf42bb5f9
parentWipe out older ebuilds of x11-plugins/wmnd (diff)
downloadhistorical-7468dd65ca55da1a9b319486f5133aa13db4f5c0.tar.gz
historical-7468dd65ca55da1a9b319486f5133aa13db4f5c0.tar.bz2
historical-7468dd65ca55da1a9b319486f5133aa13db4f5c0.zip
minor touchups to the ebuild
-rw-r--r--sys-apps/groff/ChangeLog5
-rw-r--r--sys-apps/groff/Manifest4
-rw-r--r--sys-apps/groff/groff-1.19.1.ebuild23
3 files changed, 17 insertions, 15 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index a16d07811a15..ae1c56472b16 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/groff
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.42 2004/09/13 05:43:42 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.43 2004/09/13 07:29:55 solar Exp $
+
+ 13 Sep 2004; <solar@gentoo.org> groff-1.19.1.ebuild:
+ minor touchups to the ebuild
*groff-1.19.1 (13 Sep 2004)
diff --git a/sys-apps/groff/Manifest b/sys-apps/groff/Manifest
index 3749fc41afe5..385e330813e8 100644
--- a/sys-apps/groff/Manifest
+++ b/sys-apps/groff/Manifest
@@ -1,10 +1,10 @@
MD5 0731e5193754b6fcbc962d13f0eef29b groff-1.18.1-r4.ebuild 3146
-MD5 59a73f905a8359ce86228f1352ce0330 groff-1.19.1.ebuild 3315
+MD5 4529f59a57c05a82ed794e90442952db groff-1.19.1.ebuild 3363
MD5 04bb47e5545e19beeb54970d16368d90 groff-1.18.1-r1.ebuild 2303
MD5 a5e8030b4580d14da6770c540d755c11 groff-1.18.1-r3.ebuild 2985
MD5 3c5cf62ff5c8b1393960a31a8ea2a610 groff-1.19.ebuild 3307
MD5 d68bb03ebc39a7b8a3c546424bba7132 groff-1.18.1-r2.ebuild 2834
-MD5 b29505c68d2a967fcb3414456d84d85b ChangeLog 5997
+MD5 336577f88efe462274836f25ad92aeae ChangeLog 6084
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 a94a3de58bb54769a2793e1f8602a618 files/groff_1.18.1-7-fix.patch 551
MD5 e0ea59264695cc68dc9947e4611dde5d files/groff-man-UTF-8.diff 391
diff --git a/sys-apps/groff/groff-1.19.1.ebuild b/sys-apps/groff/groff-1.19.1.ebuild
index 3ff1b8f1bcbb..462cf64eb8b0 100644
--- a/sys-apps/groff/groff-1.19.1.ebuild
+++ b/sys-apps/groff/groff-1.19.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1.ebuild,v 1.1 2004/09/13 05:43:42 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1.ebuild,v 1.2 2004/09/13 07:29:55 solar Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic gcc
MB_PATCH="groff_1.18.1-7" #"${P/-/_}-7"
DESCRIPTION="Text formatter used for man pages"
@@ -45,15 +45,15 @@ src_unpack() {
# Fix syntax error in pic2graph. Closes #32300.
sed -i -e "s:groffpic_opts=\"-U\":groffpic_opts=\"-U\";;:" \
- contrib/pic2graph/pic2graph.sh
+ contrib/pic2graph/pic2graph.sh || die
}
src_compile() {
local myconf=
# Fix problems with not finding g++
- [ -z "${CC}" ] && export CC="gcc"
- [ -z "${CXX}" ] && export CXX="g++"
+ export CC="$(gcc-getCC)"
+ export CXX="$(gcc-getCXX)"
case ${ARCH} in
alpha)
@@ -76,13 +76,12 @@ src_compile() {
# ready for production use."
filter-flags -fnew-ra
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=\${inforoot} \
- ${myconf} || die
+ # many fun sandbox errors with econf
+ myconf="${myconf} --host=${CHOST} --prefix=/usr \
+ --mandir=/usr/share/man --infodir=\${inforoot}"
+ ./configure ${myconf} || die
- # Parallel build doesn't work
+ # Parallel build doesn't work. Patched wanted.
emake -j1 || die
# Only build X stuff if we have X installed, but do
@@ -119,6 +118,6 @@ src_install() {
dosym soelim /usr/bin/zsoelim
cd ${S}
- dodoc BUG-REPORT COPYING ChangeLog FDL MORE.STUFF NEWS \
+ dodoc BUG-REPORT ChangeLog FDL MORE.STUFF NEWS \
PROBLEMS PROJECTS README REVISION TODO VERSION
}