summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-07-12 00:52:26 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-07-12 00:52:26 +0000
commit88f89f286f66f8456fa177ef2e5463fae120487c (patch)
tree1bb8e3e3085a832f003642d14d3014c5fa4f3eec
parentStable on x86. (diff)
downloadhistorical-88f89f286f66f8456fa177ef2e5463fae120487c.tar.gz
historical-88f89f286f66f8456fa177ef2e5463fae120487c.tar.bz2
historical-88f89f286f66f8456fa177ef2e5463fae120487c.zip
Version bump, keyword ~alpha.
-rw-r--r--net-misc/rsnapshot/ChangeLog7
-rw-r--r--net-misc/rsnapshot/Manifest4
-rw-r--r--net-misc/rsnapshot/files/digest-rsnapshot-1.1.61
-rw-r--r--net-misc/rsnapshot/rsnapshot-1.1.6.ebuild45
4 files changed, 55 insertions, 2 deletions
diff --git a/net-misc/rsnapshot/ChangeLog b/net-misc/rsnapshot/ChangeLog
index f41f209cc738..df5f9a0d5687 100644
--- a/net-misc/rsnapshot/ChangeLog
+++ b/net-misc/rsnapshot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/rsnapshot
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsnapshot/ChangeLog,v 1.8 2004/06/28 09:12:58 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsnapshot/ChangeLog,v 1.9 2004/07/12 00:52:26 kloeri Exp $
+
+*rsnapshot-1.1.6 (12 Jul 2004)
+
+ 12 Jul 2004; Bryan Østergaard <kloeri@gentoo.org> +rsnapshot-1.1.6.ebuild:
+ Version bump, keyword ~alpha.
*rsnapshot-1.1.5 (28 Jun 2004)
diff --git a/net-misc/rsnapshot/Manifest b/net-misc/rsnapshot/Manifest
index 3d7f31b0ea7f..b48dbfa888bd 100644
--- a/net-misc/rsnapshot/Manifest
+++ b/net-misc/rsnapshot/Manifest
@@ -1,6 +1,8 @@
MD5 80b11414816b11596f97e63173d727cd rsnapshot-1.1.4.ebuild 1124
+MD5 6cdaeb4f01b184b1d2263a2e12b8f3a3 rsnapshot-1.1.6.ebuild 1131
MD5 dfa142becbc66bbe954921b07bb25793 rsnapshot-1.1.5.ebuild 1124
-MD5 6c986b1218bd0de9318ad09f91f2a8c4 ChangeLog 1338
+MD5 f5f2128bedf8fd2612613730d725a2f1 ChangeLog 1480
MD5 3125bec127754bb5fb5fd85f47d9ff4c metadata.xml 202
MD5 315eef7b4a2572bb536a9f331ef3cab8 files/digest-rsnapshot-1.1.4 66
MD5 07f44ec1f0dbf2c14a715674d0a63df2 files/digest-rsnapshot-1.1.5 66
+MD5 5cb328274e5b013d754bfb3993ca7c57 files/digest-rsnapshot-1.1.6 66
diff --git a/net-misc/rsnapshot/files/digest-rsnapshot-1.1.6 b/net-misc/rsnapshot/files/digest-rsnapshot-1.1.6
new file mode 100644
index 000000000000..a862a99efb10
--- /dev/null
+++ b/net-misc/rsnapshot/files/digest-rsnapshot-1.1.6
@@ -0,0 +1 @@
+MD5 865b68d3c952812d9a3fc982d514ccfa rsnapshot-1.1.6.tar.gz 88871
diff --git a/net-misc/rsnapshot/rsnapshot-1.1.6.ebuild b/net-misc/rsnapshot/rsnapshot-1.1.6.ebuild
new file mode 100644
index 000000000000..7276c8a89a64
--- /dev/null
+++ b/net-misc/rsnapshot/rsnapshot-1.1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsnapshot/rsnapshot-1.1.6.ebuild,v 1.1 2004/07/12 00:52:26 kloeri Exp $
+
+inherit eutils
+
+DESCRIPTION="rsnapshot is a filesystem backup utility based on rsync."
+HOMEPAGE="http://www.rsnapshot.org"
+SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8.2
+ >=sys-apps/util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ >=net-misc/openssh-3.7.1_p2-r1
+ >=net-misc/rsync-2.6.0"
+
+src_compile() {
+ econf \
+ --prefix=/usr \
+ --sysconfdir=/etc || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The configuration file: "
+ einfo " /etc/rsnapshot.conf.default "
+ einfo " has been installed. "
+ einfo "This is a template. "
+ einfo "Copy, or move, the above file to: "
+ einfo " /etc/rsnapshot.conf "
+ einfo "Note that upgrading will update "
+ einfo " the template, not real config. "
+ einfo
+}