summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-26 03:27:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-26 03:27:03 +0000
commit97ef23a808d7894a661e3887151dab10e6ae69d5 (patch)
tree5c16778384e6e47a3f22978ef68ec2b92a417900
parentold (diff)
downloadhistorical-97ef23a808d7894a661e3887151dab10e6ae69d5.tar.gz
historical-97ef23a808d7894a661e3887151dab10e6ae69d5.tar.bz2
historical-97ef23a808d7894a661e3887151dab10e6ae69d5.zip
old
Package-Manager: portage-2.1.4.4
-rw-r--r--games-puzzle/flobopuyo/flobopuyo-0.20.ebuild52
-rw-r--r--games-puzzle/ltris/ltris-1.0.11.ebuild54
-rw-r--r--games-puzzle/pathological/pathological-1.1.3-r1.ebuild69
-rw-r--r--games-puzzle/pauker/pauker-1.6.1.ebuild29
4 files changed, 0 insertions, 204 deletions
diff --git a/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild b/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild
deleted file mode 100644
index c56329154b00..000000000000
--- a/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild,v 1.10 2006/04/11 19:45:53 flameeyes Exp $
-
-inherit toolchain-funcs eutils games
-
-DESCRIPTION="Clone of the famous PuyoPuyo game"
-HOMEPAGE="http://www.ios-software.com/?page=projet&quoi=29"
-SRC_URI="http://www.ios-software.com/flobopuyo/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
-IUSE="opengl"
-
-DEPEND="media-libs/libsdl
- media-libs/sdl-image
- media-libs/sdl-mixer
- opengl? ( virtual/opengl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch \
- "${FILESDIR}"/${P}-gcc4.patch \
- "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-libs.patch
-
- find . -type f -name ".*" -exec rm -f \{\} \;
- sed -i \
- -e "/strip/d" \
- -e "s:^DATADIR=.*:DATADIR=\"${GAMES_DATADIR}/${PN}\":" \
- -e "/^INSTALL_BINDIR/s:/\$(PREFIX)/games:${GAMES_BINDIR}:" \
- -e "s:^CFLAGS=:CFLAGS+=:" \
- -e "/^LDFLAGS=/d" \
- Makefile \
- || die "sed failed"
-}
-
-src_compile() {
- use opengl && want_opengl=true || want_opengl=false
- emake CC="$(tc-getCXX)" CXX="$(tc-getCXX)" \
- ENABLE_OPENGL="${want_opengl}" || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc Changelog TODO
- doman man/flobopuyo.6
- prepgamesdirs
-}
diff --git a/games-puzzle/ltris/ltris-1.0.11.ebuild b/games-puzzle/ltris/ltris-1.0.11.ebuild
deleted file mode 100644
index 75f410d4c420..000000000000
--- a/games-puzzle/ltris/ltris-1.0.11.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ltris-1.0.11.ebuild,v 1.8 2008/03/07 19:16:33 wolf31o2 Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-inherit autotools eutils games
-
-DESCRIPTION="very polished Tetris clone"
-HOMEPAGE="http://lgames.sourceforge.net/"
-SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="nls"
-
-RDEPEND="media-libs/libsdl
- media-libs/sdl-mixer
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if use nls ; then
- sed -i \
- -e '/^localedir/s:$(datadir):/usr/share:' \
- po/Makefile.in.in \
- || die "sed failed"
- sed -i \
- -e '/^localedir/s:$datadir:/usr/share:' \
- configure.in \
- || die "sed failed"
- AT_M4DIR=m4 eautoreconf
- fi
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- --with-highscore-path="${GAMES_STATEDIR}" \
- $(use_enable nls) || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README TODO
- newicon icons/ltris48.xpm ${PN}.xpm
- make_desktop_entry ltris LTris ${PN}
- prepgamesdirs
-}
diff --git a/games-puzzle/pathological/pathological-1.1.3-r1.ebuild b/games-puzzle/pathological/pathological-1.1.3-r1.ebuild
deleted file mode 100644
index a90e671677b1..000000000000
--- a/games-puzzle/pathological/pathological-1.1.3-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pathological/pathological-1.1.3-r1.ebuild,v 1.7 2008/02/29 19:37:46 carlo Exp $
-
-inherit eutils games
-
-DESCRIPTION="An enriched clone of the game 'Logical' by Rainbow Arts"
-HOMEPAGE="http://pathological.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc sparc x86"
-IUSE="doc"
-
-DEPEND="doc? ( media-libs/netpbm )"
-RDEPEND=">=dev-python/pygame-1.5.5"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- unpack ./${PN}.6.gz
-
- epatch "${FILESDIR}"/${P}-build.patch
- epatch "${FILESDIR}"/${P}-music-py.patch
-
- if use doc ; then
- sed -i \
- -e '5,$ s/=/ /g' makehtml \
- || die "sed makehtml failed"
- else
- echo "#!/bin/sh" > makehtml
- fi
-
- sed -i \
- -e "s:/usr/share/games:${GAMES_DATADIR}:" \
- -e "s:/var/games:${GAMES_STATEDIR}:" \
- -e "s:exec:exec python:" \
- ${PN} || die "sed ${PN} failed"
-
- sed -i \
- -e "s:/usr/lib/${PN}/bin:$(games_get_libdir)/${PN}:" \
- ${PN}.py || die "sed ${PN}.py failed"
-}
-
-src_install() {
- dogamesbin ${PN} || die "dogamesbin failed"
-
- exeinto "$(games_get_libdir)"/${PN}
- doexe write-highscores || die "doexe failed"
-
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r circuits graphics music sounds ${PN}.py || die "doins data failed"
-
- insinto "${GAMES_STATEDIR}"
- doins ${PN}_scores || die "doins scores failed"
- fperms 660 "${GAMES_STATEDIR}"/${PN}_scores
-
- dodoc changelog README TODO
- doman ${PN}.6
- use doc && dohtml -r html/*
-
- doicon ${PN}.xpm
- make_desktop_entry ${PN} Pathological ${PN}
-
- # remove some unneeded resource files
- rm -f "${D}/${GAMES_DATADIR}"/${PN}/graphics/*.xcf
- prepgamesdirs
-}
diff --git a/games-puzzle/pauker/pauker-1.6.1.ebuild b/games-puzzle/pauker/pauker-1.6.1.ebuild
deleted file mode 100644
index 0efc051e8bf9..000000000000
--- a/games-puzzle/pauker/pauker-1.6.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pauker/pauker-1.6.1.ebuild,v 1.2 2006/03/24 05:47:15 mr_bones_ Exp $
-
-inherit games
-
-DESCRIPTION="A java based flashcard program"
-HOMEPAGE="http://pauker.sourceforge.net"
-SRC_URI="mirror://sourceforge/pauker/${P}.jar"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.4"
-
-src_unpack() {
- mkdir -p "${S}"
- cp "${DISTDIR}/${P}.jar" "${S}" || die "cp failed"
-}
-
-src_install() {
- local jar="pauker.jar"
- insinto "${GAMES_PREFIX_OPT}/${PN}"
- newins "${P}.jar" ${jar} || die "newins failed"
- games_make_wrapper ${PN} "java -jar ./${jar}" "${GAMES_PREFIX_OPT}/${PN}"
- prepgamesdirs
-}