summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-26 11:04:16 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-26 11:04:16 +0000
commita76749f4b93cdc1bffbc8d4ad4a777250606f5dc (patch)
treea38e9a925aae22ad18d2f49381fd64331f3edb4b
parentNew snapshot, avfilter and new include layout in (diff)
downloadhistorical-a76749f4b93cdc1bffbc8d4ad4a777250606f5dc.tar.gz
historical-a76749f4b93cdc1bffbc8d4ad4a777250606f5dc.tar.bz2
historical-a76749f4b93cdc1bffbc8d4ad4a777250606f5dc.zip
Version bump
Package-Manager: portage-2.1.4.4
-rw-r--r--net-im/silc-client/ChangeLog7
-rw-r--r--net-im/silc-client/silc-client-1.1.4.ebuild83
-rw-r--r--net-im/silc-server/ChangeLog7
-rw-r--r--net-im/silc-server/silc-server-1.1.2.ebuild75
-rw-r--r--net-im/silc-toolkit/ChangeLog7
-rw-r--r--net-im/silc-toolkit/silc-toolkit-1.1.7.ebuild60
6 files changed, 236 insertions, 3 deletions
diff --git a/net-im/silc-client/ChangeLog b/net-im/silc-client/ChangeLog
index e92db0e477ef..c0771aa74330 100644
--- a/net-im/silc-client/ChangeLog
+++ b/net-im/silc-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/silc-client
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.49 2008/02/14 21:49:00 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.50 2008/03/26 11:00:29 armin76 Exp $
+
+*silc-client-1.1.4 (26 Mar 2008)
+
+ 26 Mar 2008; Raúl Porcel <armin76@gentoo.org> +silc-client-1.1.4.ebuild:
+ Version bump
14 Feb 2008; Santiago M. Mola <coldwind@gentoo.org>
silc-client-1.1.3.ebuild:
diff --git a/net-im/silc-client/silc-client-1.1.4.ebuild b/net-im/silc-client/silc-client-1.1.4.ebuild
new file mode 100644
index 000000000000..c962831af5ca
--- /dev/null
+++ b/net-im/silc-client/silc-client-1.1.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-1.1.4.ebuild,v 1.1 2008/03/26 11:00:29 armin76 Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 perl debug"
+
+DEPEND="perl? ( dev-lang/perl )
+ sys-libs/ncurses
+ dev-util/pkgconfig
+ >=dev-libs/glib-2.8
+ !<=net-im/silc-toolkit-0.9.12-r1"
+
+RDEPEND="${DEPEND}
+ perl? (
+ !net-irc/irssi
+ !net-irc/irssi-svn
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:-g -O2:${CFLAGS}:g" configure
+ use amd64 && sed -i -e 's:felf\([^6]\):felf64\1:g' configure
+ epatch "${FILESDIR}/${PN}-1.1-docdir.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ econf \
+ --datadir=/usr/share/${PN} \
+ --datarootdir=/usr/share/${PN} \
+ --mandir=/usr/share/man \
+ --includedir=/usr/include/${PN} \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/${PN}/help \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-optimizations \
+ $(use_enable debug) \
+ ${myconf}
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ local myflags=""
+
+ if use perl
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=/usr/$(get_libdir)"
+ myflags="${myflags} INSTALLARCHLIB=${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${perl_sitearch}"
+ fi
+
+ make DESTDIR="${D}" ${myflags} install || die "make install failed"
+
+ rm -rf "${D}"/etc "${D}"/usr/libsilc* "${D}"/usr/include
+
+ dodoc CHANGES CREDITS README TODO
+ cd "${S}/apps/irssi"
+ dodoc silc.conf docs/formats.txt docs/manual.txt docs/signals.txt docs/special_vars.txt
+ dohtml docs/startup-HOWTO.html
+
+ insinto /usr/share/silc-client/help
+ rm docs/help/Make*
+ doins docs/help/*
+}
diff --git a/net-im/silc-server/ChangeLog b/net-im/silc-server/ChangeLog
index 33f5d3ad841c..a729e1eddafa 100644
--- a/net-im/silc-server/ChangeLog
+++ b/net-im/silc-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/silc-server
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-server/ChangeLog,v 1.30 2008/02/14 21:52:02 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-server/ChangeLog,v 1.31 2008/03/26 10:58:49 armin76 Exp $
+
+*silc-server-1.1.2 (26 Mar 2008)
+
+ 26 Mar 2008; Raúl Porcel <armin76@gentoo.org> +silc-server-1.1.2.ebuild:
+ Version bump
14 Feb 2008; Santiago M. Mola <coldwind@gentoo.org>
silc-server-1.1.ebuild:
diff --git a/net-im/silc-server/silc-server-1.1.2.ebuild b/net-im/silc-server/silc-server-1.1.2.ebuild
new file mode 100644
index 000000000000..7f6209df4b1f
--- /dev/null
+++ b/net-im/silc-server/silc-server-1.1.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-server/silc-server-1.1.2.ebuild,v 1.1 2008/03/26 10:58:49 armin76 Exp $
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Server for Secure Internet Live Conferencing"
+SRC_URI="http://www.silcnet.org/download/server/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ipv6 debug"
+
+RDEPEND="!<=net-im/silc-toolkit-0.9.12-r1
+ !<=net-im/silc-client-1.0.1"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/1.1-execstack.patch
+}
+
+src_compile() {
+ econf \
+ --datadir=/usr/share/${PN} \
+ --datarootdir=/usr/share/${PN} \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/${PN}/help \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-optimizations \
+ --with-logsdir=/var/log/${PN} \
+ --with-silcd-pid-file=/var/run/silcd.pid \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/*.conf
+
+ fperms 600 /etc/silc
+ keepdir /var/log/${PN}
+
+ rm -rf \
+ "${D}"/usr/libsilc* \
+ "${D}"/usr/include \
+ "${D}"/etc/silc/silcd.{pub,prv}
+
+ newinitd "${FILESDIR}/silcd.initd" silcd
+
+ sed -i \
+ -e 's:10.2.1.6:0.0.0.0:' \
+ -e 's:User = "nobody";:User = "silcd";:' \
+ "${D}"/etc/silc/silcd.conf
+}
+
+pkg_postinst() {
+ enewuser silcd
+
+ if [ ! -f "${ROOT}"/etc/silc/silcd.prv ] ; then
+ einfo "Creating key pair in /etc/silc"
+ silcd -C "${ROOT}"/etc/silc
+ chmod 600 "${ROOT}"/etc/silc/silcd.{prv,pub}
+ fi
+}
diff --git a/net-im/silc-toolkit/ChangeLog b/net-im/silc-toolkit/ChangeLog
index ac71eecc6dd8..75226b56e06d 100644
--- a/net-im/silc-toolkit/ChangeLog
+++ b/net-im/silc-toolkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/silc-toolkit
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-toolkit/ChangeLog,v 1.83 2008/03/14 08:23:08 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-toolkit/ChangeLog,v 1.84 2008/03/26 11:04:16 armin76 Exp $
+
+*silc-toolkit-1.1.7 (26 Mar 2008)
+
+ 26 Mar 2008; Raúl Porcel <armin76@gentoo.org> +silc-toolkit-1.1.7.ebuild:
+ Version bump
14 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
silc-toolkit-1.1.6.ebuild:
diff --git a/net-im/silc-toolkit/silc-toolkit-1.1.7.ebuild b/net-im/silc-toolkit/silc-toolkit-1.1.7.ebuild
new file mode 100644
index 000000000000..16082924b10f
--- /dev/null
+++ b/net-im/silc-toolkit/silc-toolkit-1.1.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-toolkit/silc-toolkit-1.1.7.ebuild,v 1.1 2008/03/26 11:04:16 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="SDK for the SILC protocol"
+HOMEPAGE="http://silcnet.org/"
+SRC_URI="http://silcnet.org/download/toolkit/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6"
+
+RDEPEND=""
+DEPEND="dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ # They have incorrect DESTDIR usage
+ sed -i '/\$(srcdir)\/tutorial/s/\$(prefix)/\$(docdir)/' "${S}"/Makefile.{am,in}
+ sed -i \
+ "s/^\(pkgconfigdir =\) \$(libdir)\/pkgconfig/\1 \/usr\/$(get_libdir)\/pkgconfig/"\
+ "${S}"/lib/Makefile.{am,in}
+}
+
+src_compile() {
+ local myconf=""
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ econf \
+ --datadir=/usr/share/${PN} \
+ --datarootdir=/usr/share/${PN} \
+ --mandir=/usr/share/man \
+ --includedir=/usr/include/${PN} \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/${PN}/help \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-optimizations \
+ --with-simdir=/usr/$(get_libdir)/${PN}/modules \
+ $(use_enable debug) \
+ ${myconf}
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm -rf \
+ "${D}"/etc/${PN}/silcd.conf \
+ "${D}"/usr/share/man \
+ "${D}"/usr/share/doc/${PF}/examples \
+ "${D}"/usr/share/silc-toolkit \
+ "${D}"/var/log/silc-toolkit \
+ "${D}"/etc/silc
+}