summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-03 20:04:38 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-03 20:04:38 +0000
commiteda3b4622ed566dc649a8c9fd38d0a6c61619bb2 (patch)
tree56057d532c62d9de66b2c1e86b1f4c061f20e568 /app-accessibility/speech-dispatcher
parentForce groff-1.18 (no i18n patch for 1.19 available atm) (diff)
downloadhistorical-eda3b4622ed566dc649a8c9fd38d0a6c61619bb2.tar.gz
historical-eda3b4622ed566dc649a8c9fd38d0a6c61619bb2.tar.bz2
historical-eda3b4622ed566dc649a8c9fd38d0a6c61619bb2.zip
This ebuild includes the missing header file for the lib.
Diffstat (limited to 'app-accessibility/speech-dispatcher')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog8
-rw-r--r--app-accessibility/speech-dispatcher/Manifest8
-rw-r--r--app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.2-r11
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.2-r1.ebuild57
4 files changed, 70 insertions, 4 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index d8000143035a..ca0771ee95e4 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.2 2004/03/31 22:40:03 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.3 2004/04/03 20:04:38 eradicator Exp $
+
+*speech-dispatcher-0.2-r1 (03 Apr 2004)
+
+ 03 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ speech-dispatcher-0.2-r1.ebuild:
+ This ebuild includes the missing header file for the lib.
01 Apr 2004; David Holm <dholm@gentoo.org> speech-dispatcher-0.2.ebuild:
Added to ~ppc.
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
index 7d7c5ef409eb..f1277b240e7e 100644
--- a/app-accessibility/speech-dispatcher/Manifest
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -1,6 +1,8 @@
-MD5 c36ff9dc3bba0dcd3c8e4c2f82b9f0bf ChangeLog 595
-MD5 4f5d797c455932135181f0c31b5e71b2 metadata.xml 185
MD5 b45fabc785cac2e4a92fc2cd60041eb2 speech-dispatcher-0.2.ebuild 1287
+MD5 4946b1d02e2777f5f7d9021c06f1f9f9 speech-dispatcher-0.2-r1.ebuild 1353
+MD5 7a6729e8dab7c3471abeae9b0273f2de ChangeLog 794
+MD5 4f5d797c455932135181f0c31b5e71b2 metadata.xml 185
MD5 078d5c317522b72b8d9aa82719ee3440 files/digest-speech-dispatcher-0.2 63
-MD5 d693a3d215850d96ac42347e854e40bd files/speech-dispatcher 670
MD5 6dc3b85b3d0bdff46846556206bbded1 files/speech-dispatcher-0.2-gentoo.patch 2251
+MD5 078d5c317522b72b8d9aa82719ee3440 files/digest-speech-dispatcher-0.2-r1 63
+MD5 d693a3d215850d96ac42347e854e40bd files/speech-dispatcher 670
diff --git a/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.2-r1 b/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.2-r1
new file mode 100644
index 000000000000..5031a085ee0c
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.2-r1
@@ -0,0 +1 @@
+MD5 3671404d27c211e70f5411ca9ed7bf09 speechd-0.2.tar.gz 739792
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.2-r1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.2-r1.ebuild
new file mode 100644
index 000000000000..e9214c455f86
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.2-r1.ebuild,v 1.1 2004/04/03 20:04:38 eradicator Exp $
+
+inherit eutils libtool
+
+MY_PN="speechd"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-libs/dotconf
+ >=app-accessibility/flite-1.2
+ >=dev-libs/glib-2
+ media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.7.8
+ >=sys-devel/autoconf-2.58"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ export WANT_AUTOMAKE=1.7
+ export WANT_AUTOCONF=2.5
+
+ epatch ${FILESDIR}/speech-dispatcher-${PV}-gentoo.patch
+ autoreconf || die "Could not update configure script with autoconf/automake"
+ elibtoolize
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ mv ${D}/usr/bin/speechd ${D}/usr/bin/speech-dispatcher
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/speech-dispatcher
+
+ insinto /usr/include
+ doins ${S}/src/c/api/libspeechd.h
+}
+
+pkg_postinst() {
+ echo
+ einfo "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+ echo
+}