summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-08-24 17:21:43 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-08-24 17:21:43 +0000
commit62e9362a0a3c6b1daf5b59e3e25236fb76e7df9b (patch)
tree8d0f05d3ca90f3fb42aa8beae854833cb6a1342b /app-admin/gamin/gamin-0.0.6-r2.ebuild
parentVersion bump to 1.0.1. blas-config is now CONF_LIBDIR aware. (diff)
downloadhistorical-62e9362a0a3c6b1daf5b59e3e25236fb76e7df9b.tar.gz
historical-62e9362a0a3c6b1daf5b59e3e25236fb76e7df9b.tar.bz2
historical-62e9362a0a3c6b1daf5b59e3e25236fb76e7df9b.zip
Sources is using wrong DEFINE to check if INotify should be enabled.
Diffstat (limited to 'app-admin/gamin/gamin-0.0.6-r2.ebuild')
-rw-r--r--app-admin/gamin/gamin-0.0.6-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/gamin/gamin-0.0.6-r2.ebuild b/app-admin/gamin/gamin-0.0.6-r2.ebuild
new file mode 100644
index 000000000000..5804149dfced
--- /dev/null
+++ b/app-admin/gamin/gamin-0.0.6-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.0.6-r2.ebuild,v 1.1 2004/08/24 17:21:43 azarah Exp $
+
+inherit eutils
+
+INOTIFY_VER="0.8.1"
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=
+
+DEPEND="virtual/libc
+ >=dev-libs/glib-2.0
+ !app-admin/fam"
+
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/server
+ if [ -f "/usr/src/linux/include/linux/inotify.h" ]
+ then
+ cp /usr/src/linux/include/linux/inotify.h .
+ elif [ -f "/usr/include/linux/inotify.h" ]
+ then
+ cp /usr/include/linux/inotify.h .
+ else
+ cp "${FILESDIR}/inotify-${INOTIFY_VER}.h" inotify.h
+ fi
+
+ # Include our inotify.h
+ epatch ${FILESDIR}/${P}-inotify_h-include.patch
+ # Select the backend at runtime
+ epatch ${FILESDIR}/${P}-runtime-backend-select.patch
+ # Sources is using wrong DEFINE to check if INotify should be enabled ...
+ epatch ${FILESDIR}/${P}-actually-enable-inotify-support.patch
+}
+
+src_compile() {
+ econf --enable-inotify \
+ --enable-debug || die
+ # Enable debug for testing the runtime backend patch
+
+ # Currently not smp safe
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING ChangeLog Copyright README TODO
+}