summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2012-08-02 18:10:04 +0000
committerJosé María Alonso <nimiux@gentoo.org>2012-08-02 18:10:04 +0000
commit654f5398d25898d69e5269482ee1b36f775fbf3b (patch)
tree2e1cf79075aabe1117e53a4db06f79f077d597c3 /app-admin/logrotate/logrotate-3.8.2.ebuild
parentKeyword amd64-linux and x86-linux (diff)
downloadhistorical-654f5398d25898d69e5269482ee1b36f775fbf3b.tar.gz
historical-654f5398d25898d69e5269482ee1b36f775fbf3b.tar.bz2
historical-654f5398d25898d69e5269482ee1b36f775fbf3b.zip
[app-admin/logrotate] Version bump.
Package-Manager: portage-2.1.10.65/cvs/Linux i686
Diffstat (limited to 'app-admin/logrotate/logrotate-3.8.2.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.8.2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/app-admin/logrotate/logrotate-3.8.2.ebuild b/app-admin/logrotate/logrotate-3.8.2.ebuild
new file mode 100644
index 000000000000..4f15d93fcadf
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.8.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.8.2.ebuild,v 1.1 2012/08/02 18:10:04 nimiux Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://fedorahosted.org/logrotate/"
+SRC_URI="https://fedorahosted.org/releases/l/o/logrotate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="acl selinux"
+
+RDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? (
+ sys-libs/libselinux
+ sec-policy/selinux-logrotate
+ )
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ strip-flags
+
+ epatch \
+ "${FILESDIR}"/${PN}-3.7.7-datehack.patch \
+ "${FILESDIR}"/${PN}-3.8.0-ignore-hidden.patch \
+ "${FILESDIR}"/${PN}-3.8.0-fbsd.patch \
+ "${FILESDIR}"/${PN}-3.8.1-noasprintf.patch \
+ "${FILESDIR}"/${PN}-3.8.2-atomic-create.patch
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ local myconf
+ myconf="CC=$(tc-getCC)"
+ use selinux && myconf="${myconf} WITH_SELINUX=yes"
+ use acl && myconf="${myconf} WITH_ACL=yes"
+ emake ${myconf} RPM_OPT_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ insinto /usr
+ dosbin logrotate
+ doman logrotate.8
+ dodoc CHANGES examples/logrotate*
+
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/logrotate.cron
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+}