summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-05-02 13:35:39 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-05-02 13:35:39 +0000
commit6144faef261a904c46e589204f51b77cc25ad0ff (patch)
treec4f5e746c0210f3be2cfcddfffd15cbe9159800c /app-admin/stow/stow-2.2.0.ebuild
parent[bump] dev-perl/XML-LibXML-1.970.0 (diff)
downloadhistorical-6144faef261a904c46e589204f51b77cc25ad0ff.tar.gz
historical-6144faef261a904c46e589204f51b77cc25ad0ff.tar.bz2
historical-6144faef261a904c46e589204f51b77cc25ad0ff.zip
Bump to 2.2.0, addind DEPEND for tests
Package-Manager: portage-2.1.10.57/cvs/Linux x86_64
Diffstat (limited to 'app-admin/stow/stow-2.2.0.ebuild')
-rw-r--r--app-admin/stow/stow-2.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/stow/stow-2.2.0.ebuild b/app-admin/stow/stow-2.2.0.ebuild
new file mode 100644
index 000000000000..9f36cbcdee48
--- /dev/null
+++ b/app-admin/stow/stow-2.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/stow/stow-2.2.0.ebuild,v 1.1 2012/05/02 13:35:39 maksbotan Exp $
+
+EAPI="2"
+
+DESCRIPTION="Manage installation of software in /var/lib/"
+HOMEPAGE="http://www.gnu.org/software/stow/"
+SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ test? (
+ virtual/perl-Test-Harness
+ dev-perl/Test-Output
+ )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # create new STOWDIR
+ dodir /var/lib/stow
+
+ # install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}"/99stow || die "doenvd failed"
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/stow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264 for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/stow/bin."
+}