summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-13 21:55:03 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-13 21:55:03 +0000
commitdc139238e911aab43bd39805fb6d8b3bf4dc3d77 (patch)
tree673c5ff98682c37a78f6173a5e6e85a552101813 /app-arch/dump
parentAdded ppc keyword (diff)
downloadhistorical-dc139238e911aab43bd39805fb6d8b3bf4dc3d77.tar.gz
historical-dc139238e911aab43bd39805fb6d8b3bf4dc3d77.tar.bz2
historical-dc139238e911aab43bd39805fb6d8b3bf4dc3d77.zip
Version bump.
Diffstat (limited to 'app-arch/dump')
-rw-r--r--app-arch/dump/ChangeLog16
-rw-r--r--app-arch/dump/dump-0.4.31.ebuild64
-rw-r--r--app-arch/dump/files/digest-dump-0.4.311
3 files changed, 73 insertions, 8 deletions
diff --git a/app-arch/dump/ChangeLog b/app-arch/dump/ChangeLog
index 966244531494..91e9e8400095 100644
--- a/app-arch/dump/ChangeLog
+++ b/app-arch/dump/ChangeLog
@@ -1,26 +1,29 @@
# ChangeLog for app-arch/dump
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.6 2002/07/27 16:57:07 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.7 2002/08/13 21:55:03 raker Exp $
+
+*dump-0.4.31 (13 Aug 2002)
+
+ 13 Aug 2002; Nick Hadaway <raker@gentoo.org>
+ dump-0.4.31.ebuild, files/digest-dump-0.4.31 :
+ Version bump.
*dump-0.4.30 (27 Jul 2002)
27 Jul 2002; Nick Hadaway <raker@gentoo.org>
- dump-0.4.30.ebuild, files/digest-dump-0.4.30
-
+ dump-0.4.30.ebuild, files/digest-dump-0.4.30 :
Version bump.
*dump-0.4.29 (11 Jul 2002)
11 Jul 2002; Seemant Kulleen <seemant@gentoo.org> dump-0.4.29.ebuild
files/digest-dump-0.4.29 :
-
Version bump.
*dump-0.4.28-r1 (5 Jun 2002)
5 Jun 2002; Seemant Kulleen <seemant@gentoo.org> dump-0.4.28-r1.ebuild
files/digest-dump-0.4.28-r1 :
-
Fixed the dumpdates directory to /etc/dumpdates instead of /etc, and also
made readline an optional dependency. Closes bug #3403 by
shane@trontech.net (Shane Hyde)
@@ -29,14 +32,12 @@
26 Apr 2002; Seemant Kulleen <seemant@gentoo.org> dump-0.4.28.ebuild
files/digest-dump-0.4.28, dump-0.4.24-r1.ebuild :
-
Cleaned up the old ebuild to give a better example, and version bumped.
*dump-0.4.24-r1 (24 Apr 2002)
24 Apr 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
dump-0.4.24-r1.ebuild, files/digest-dump-0.4.24-r1 :
-
Fixed sandbox violations. Create statically linked binaries (dump
uses bzip2 whose libs are on /usr). Resovles #1873, #1986. Thanks to
kingsqueak@kingsqueak.org for the initial patch.
@@ -45,7 +46,6 @@
*dump-0.4.24 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/app-arch/dump/dump-0.4.31.ebuild b/app-arch/dump/dump-0.4.31.ebuild
new file mode 100644
index 000000000000..980191aab40c
--- /dev/null
+++ b/app-arch/dump/dump-0.4.31.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.31.ebuild,v 1.1 2002/08/13 21:55:03 raker Exp $
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+SRC_URI="http://download.sourceforge.net/dump/${MY_P}.tar.gz"
+HOMEPAGE="http://dump.sourceforge.net"
+
+DEPEND=">=sys-apps/e2fsprogs-1.27
+ >=sys-apps/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4
+ sys-kernel/linux-headers
+ readline? ( sys-libs/readline )"
+
+RDEPEND="sys-apps/star"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ use readline && ( \
+ for i in configure configure.in
+ do
+ cp ${i} ${i}.orig
+ sed "s:-ltermcap:-lncurses:g" \
+ ${i}.orig > ${i}
+ done
+ )
+}
+
+src_compile() {
+
+ local myconf
+
+ use readline \
+ && myconf="--enable-readline" \
+ || myconf="--disable-readline"
+
+ use static \
+ && myconf="${myconf} --snable-static" \
+ || myconf="${myconf} --enable-shared"
+
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-binowner=root \
+ --with-bingroup=root \
+ --enable-largefile \
+ ${myconf} || die
+
+ emake || die
+}
+src_install () {
+ einstall MANDIR=${D}/usr/share/man/man8 || die
+
+ dodoc CHANGES COPYRIGHT INSTALL KNOWNBUGS MAINTAINERS README \
+ REPORTING-BUGS THANKS TODO
+ dodoc -r examples/dump_on_cd
+}
diff --git a/app-arch/dump/files/digest-dump-0.4.31 b/app-arch/dump/files/digest-dump-0.4.31
new file mode 100644
index 000000000000..cde9740573a4
--- /dev/null
+++ b/app-arch/dump/files/digest-dump-0.4.31
@@ -0,0 +1 @@
+MD5 ef0f7e0add1e4d88a74bdd665f18804c dump-0.4b31.tar.gz 214999