summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-04 06:07:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-04 06:07:15 +0000
commit0205bd68edcd779e148447dea33d445b43a166ff (patch)
tree85f26c9076e2edef65a8f5824dcfbb843d920149 /app-arch/pax
parentnew package for pax (diff)
downloadhistorical-0205bd68edcd779e148447dea33d445b43a166ff.tar.gz
historical-0205bd68edcd779e148447dea33d445b43a166ff.tar.bz2
historical-0205bd68edcd779e148447dea33d445b43a166ff.zip
new package for pax
Diffstat (limited to 'app-arch/pax')
-rw-r--r--app-arch/pax/Manifest5
-rw-r--r--app-arch/pax/files/digest-pax-3.3.41
-rw-r--r--app-arch/pax/metadata.xml11
-rw-r--r--app-arch/pax/pax-3.3.4.ebuild39
4 files changed, 54 insertions, 2 deletions
diff --git a/app-arch/pax/Manifest b/app-arch/pax/Manifest
index ae558c8520e6..fb0296b8a8dc 100644
--- a/app-arch/pax/Manifest
+++ b/app-arch/pax/Manifest
@@ -1,3 +1,4 @@
-MD5 ac3760dc1901ff143a379b72e0181e1a pax-3.3.4.ebuild 1084
+MD5 446d973b720d7a322c772a78e97421bd pax-3.3.4.ebuild 928
+MD5 7da01de01ed79e680e0c8d31f9fce3ad ChangeLog 487
+MD5 b2e198f230feedff40fe35c8ebd65f64 metadata.xml 336
MD5 08e1b586a48fbbf71b01ebbfba9d8de8 files/digest-pax-3.3.4 65
-MD5 7c31b1bf5ebeeea55ef52f2a55d423f8 files/digest-pax-3.3.20031002 143
diff --git a/app-arch/pax/files/digest-pax-3.3.4 b/app-arch/pax/files/digest-pax-3.3.4
new file mode 100644
index 000000000000..356f39e26847
--- /dev/null
+++ b/app-arch/pax/files/digest-pax-3.3.4
@@ -0,0 +1 @@
+MD5 9fef7143d0c7c70da90f0bafe5f2d635 pax-3.3-4ras.src.rpm 165161
diff --git a/app-arch/pax/metadata.xml b/app-arch/pax/metadata.xml
new file mode 100644
index 000000000000..a03b14b60290
--- /dev/null
+++ b/app-arch/pax/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>magnet@suidzer0.org</email>
+ <name>Magnet</name>
+ <description>He's the third party maintainer through
+ seemant@gentoo.org</description>
+</maintainer>
+</pkgmetadata>
diff --git a/app-arch/pax/pax-3.3.4.ebuild b/app-arch/pax/pax-3.3.4.ebuild
new file mode 100644
index 000000000000..8a120e53d77f
--- /dev/null
+++ b/app-arch/pax/pax-3.3.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit rpm
+
+MY_PS=${P%.*}-${PV##*.}ras
+MY_P=${P%.*}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="pax (Portable Archive eXchange is the POSIX standard archive tool."
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/bin/pax/"
+SRC_URI="ftp://rpmfind.net/linux/contrib/libc6/SRPMS/${MY_PS}.src.rpm"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64"
+
+DEPEND="virtual/glibc
+ app-arch/rpm2targz"
+
+src_unpack() {
+ rpm_src_unpack
+ cd ${MY_P}
+ epatch ${WORKDIR}/pax-3.3-gcc.patch
+ epatch ${WORKDIR}/pax-3.3-modifyWarn.patch
+ epatch ${WORKDIR}/pax-3.3-doc.patch
+ epatch ${WORKDIR}/pax-3.3-bzip2.patch
+}
+
+src_compile () {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin src/pax
+ doman src/pax.1
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}