summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-08 20:57:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-08 20:57:35 +0000
commit79b5622a32db75a3a691c11c12c056f3e7edc102 (patch)
treeab55e0f8f233585735e7fe72d1a9d5b86e6c715c /app-arch/tar/tar-1.25.ebuild
parentFixing bug #337643 for real. Missed sedding out test subdirectory when test u... (diff)
downloadhistorical-79b5622a32db75a3a691c11c12c056f3e7edc102.tar.gz
historical-79b5622a32db75a3a691c11c12c056f3e7edc102.tar.bz2
historical-79b5622a32db75a3a691c11c12c056f3e7edc102.zip
Version bump wrt #344751 by Jeroen Roovers.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'app-arch/tar/tar-1.25.ebuild')
-rw-r--r--app-arch/tar/tar-1.25.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-arch/tar/tar-1.25.ebuild b/app-arch/tar/tar-1.25.ebuild
new file mode 100644
index 000000000000..bb78c7e8d4c9
--- /dev/null
+++ b/app-arch/tar/tar-1.25.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.25.ebuild,v 1.1 2010/11/08 20:57:35 ssuominen Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+
+DESCRIPTION="Use this to make tarballs :)"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="http://ftp.gnu.org/gnu/tar/${P}.tar.bz2
+ ftp://alpha.gnu.org/gnu/tar/${P}.tar.bz2
+ mirror://gnu/tar/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static userland_GNU"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+src_prepare() {
+ if ! use userland_GNU ; then
+ sed -i \
+ -e 's:/backup\.sh:/gbackup.sh:' \
+ scripts/{backup,dump-remind,restore}.in \
+ || die "sed non-GNU"
+ fi
+}
+
+src_configure() {
+ local myconf
+ use static && append-ldflags -static
+ use userland_GNU || myconf="--program-prefix=g"
+ # Work around bug in sandbox #67051
+ gl_cv_func_chown_follows_symlink=yes \
+ FORCE_UNSAFE_CONFIGURE=1 \
+ econf \
+ --enable-backup-scripts \
+ --bindir=/bin \
+ --libexecdir=/usr/sbin \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ local p=""
+ use userland_GNU || p=g
+
+ emake DESTDIR="${D}" install || die
+
+ if [[ -z ${p} ]] ; then
+ # a nasty yet required piece of baggage
+ exeinto /etc
+ doexe "${FILESDIR}"/rmt || die
+ fi
+
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS
+ newman "${FILESDIR}"/tar.1 ${p}tar.1
+ mv "${D}"/usr/sbin/${p}backup{,-tar}
+ mv "${D}"/usr/sbin/${p}restore{,-tar}
+
+ rm -f "${D}"/usr/$(get_libdir)/charset.alias
+}