summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-20 21:08:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-20 21:08:45 +0000
commit10b6c45dd4644fe144d4521f602e62c2d9ed88de (patch)
tree13b5a5708d01ef10e5664e517a036d553ae73f59 /app-cdr/cdw/cdw-0.3.95.ebuild
parentKeyword ~amd64-linux/~x86-linux (diff)
downloadhistorical-10b6c45dd4644fe144d4521f602e62c2d9ed88de.tar.gz
historical-10b6c45dd4644fe144d4521f602e62c2d9ed88de.tar.bz2
historical-10b6c45dd4644fe144d4521f602e62c2d9ed88de.zip
version bump
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'app-cdr/cdw/cdw-0.3.95.ebuild')
-rw-r--r--app-cdr/cdw/cdw-0.3.95.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-cdr/cdw/cdw-0.3.95.ebuild b/app-cdr/cdw/cdw-0.3.95.ebuild
new file mode 100644
index 000000000000..0cf4716af90e
--- /dev/null
+++ b/app-cdr/cdw/cdw-0.3.95.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdw/cdw-0.3.95.ebuild,v 1.1 2010/01/20 21:08:45 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_P=${PN}_${PV}
+DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
+HOMEPAGE="http://cdw.sourceforge.net"
+SRC_URI="mirror://sourceforge/cdw/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+RESTRICT="test" # testing code is broken
+
+DEPEND="virtual/cdrtools
+ app-cdr/dvd+rw-tools
+ dev-libs/libcdio[-minimal]
+ sys-libs/ncurses[unicode]"
+
+S=${WORKDIR}/${MY_P}/cdw
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ rm -f missing
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS THANKS \
+ doc/{KNOWN_BUGS,README*,default.conf}
+}