summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-06 06:52:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-06 06:52:00 +0000
commitb7d7cf38ac0c9004372a94d8e676fc443a7203d4 (patch)
tree951326151fcc991aeb5432cb84aa337fca83d415 /app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
parentNew ebuild (diff)
downloadhistorical-b7d7cf38ac0c9004372a94d8e676fc443a7203d4.tar.gz
historical-b7d7cf38ac0c9004372a94d8e676fc443a7203d4.tar.bz2
historical-b7d7cf38ac0c9004372a94d8e676fc443a7203d4.zip
New ebuild
Diffstat (limited to 'app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild')
-rw-r--r--app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild b/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
new file mode 100644
index 000000000000..66f4ede12d70
--- /dev/null
+++ b/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild,v 1.1 2003/05/06 06:51:56 robbat2 Exp $
+
+DESCRIPTION="GPG Keyring Manager to handle large GPG keyrings more easily"
+
+HOMEPAGE="http://www.ualberta.ca/~rbpark/gpg-ringmgr.html"
+
+SRC_URI="http://www.ualberta.ca/~rbpark/projects/${PN}"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+#This should work everywhere
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa"
+
+DEPEND="dev-lang/perl
+ >=app-crypt/gnupg-1.2.1"
+
+RDEPEND="${DEPEND}"
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ cd ${WORKDIR} && mkdir ${P}
+ cp ${DISTDIR}/${PN} ${S}
+}
+
+src_compile() {
+ pod2man ${S}/${PN} >${S}/${PN}.1
+ pod2html ${S}/${PN} >${S}/${PN}.html
+}
+
+src_install() {
+ # base install
+ dobin ${PN}
+ # now we all all the docs
+ doman ${PN}.1
+ dohtml ${PN}.html
+ # prepalldocs rocks! I saw it in net-fs/samba/samba-2.2.8
+ prepalldocs
+}