summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-01-13 18:02:39 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-01-13 18:02:39 +0000
commite27cda643ca65b861501fb8815d6671addc3c871 (patch)
tree652f60d4ec135af11af374f3df40f8258156af95 /app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
parentMarking libcdio-0.78.2-r4 ppc64 for bug 203777 (diff)
downloadhistorical-e27cda643ca65b861501fb8815d6671addc3c871.tar.gz
historical-e27cda643ca65b861501fb8815d6671addc3c871.tar.bz2
historical-e27cda643ca65b861501fb8815d6671addc3c871.zip
Initial import to the tree as per bug 129536.
Package-Manager: portage-2.1.4
Diffstat (limited to 'app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild')
-rw-r--r--app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild b/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
new file mode 100644
index 000000000000..a211d1e42d7e
--- /dev/null
+++ b/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild,v 1.1 2008/01/13 18:00:56 philantrop Exp $
+
+inherit eutils qt4
+
+MY_P="${P/_/-}"
+QCA_VER="${PV%.*}"
+
+DESCRIPTION="PKCS#11 (smartcard) plugin for QCA"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
+RESTRICT="mirror"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=app-crypt/qca-${QCA_VER}
+ >=dev-libs/pkcs11-helper-1.02"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
+ echo
+ eerror "You are trying to compile ${PN} with USE=\"debug\""
+ eerror "while qca is built without this flag. It will not work."
+ echo
+ eerror "Possible solutions to this problem are:"
+ eerror "a) install ${PN} without debug USE flag"
+ eerror "b) re-emerge qca with debug USE flag"
+ echo
+ die "can't emerge ${PN} with debug USE flag"
+ fi
+}
+
+src_compile() {
+ # cannot use econf because of non-standard configure script
+ ./configure \
+ --qtdir=/usr \
+ $(use debug && echo "--debug" || echo "--release") \
+ --no-separate-debug-info \
+ || die "configure failed"
+
+ eqmake4 ${PN}.pro
+ emake || die "make failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+ dodoc README
+}