summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-12-19 13:13:44 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-12-19 13:13:44 +0000
commit41b2c39c89cf119ff9585671fe809bafcdfa6a74 (patch)
treec8b7de5c0840b89f6ceb2d6c1ae1a45bac212685 /app-crypt/seahorse
parentStable on alpha. (diff)
downloadhistorical-41b2c39c89cf119ff9585671fe809bafcdfa6a74.tar.gz
historical-41b2c39c89cf119ff9585671fe809bafcdfa6a74.tar.bz2
historical-41b2c39c89cf119ff9585671fe809bafcdfa6a74.zip
Add patch to correctly detect gnupg-1.4.0
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/ChangeLog7
-rw-r--r--app-crypt/seahorse/Manifest13
-rw-r--r--app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch82
-rw-r--r--app-crypt/seahorse/seahorse-0.7.5.ebuild10
4 files changed, 103 insertions, 9 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index 75e1cfaf00f9..d221f763fdc3 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/seahorse
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.28 2004/12/18 23:32:02 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.29 2004/12/19 13:13:44 dragonheart Exp $
+
+ 19 Dec 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/seahorse-0.7.5-gpg1.4.patch, seahorse-0.6.3-r1.ebuild,
+ seahorse-0.7.5.ebuild:
+ Add patch to correctly detect gnupg-1.4.0
19 Dec 2004; Daniel Black <dragonheart@gentoo.org> seahorse-0.7.5.ebuild:
Elimitate package conflict with x11-misc/shared-mime-info as per bug #74793.
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index 77edd3b40431..79ad43e268c2 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1,16 +1,17 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 dc8dc039f66c58bee0c7dd119afb8717 ChangeLog 3932
+MD5 fbe67c169b3dfe46c0ac5e75962ca07e ChangeLog 4119
MD5 887271fc00711d11fb72536de7b1f7ec metadata.xml 1073
MD5 d590f30824faa32ba65691531d2d1e7a seahorse-0.6.3-r1.ebuild 807
-MD5 266ea984bd8439bc6676e1cbc9fd8775 seahorse-0.7.5.ebuild 1177
+MD5 61d80374f9e6c008a561a6640b91731e seahorse-0.7.5.ebuild 1284
MD5 052f1fee75fc120426817f6e7c0726f6 files/digest-seahorse-0.6.3-r1 66
MD5 ddd1af247311013096cded4265d69eaf files/digest-seahorse-0.7.5 67
+MD5 e1227c1335c22fcf8db3af76856b8053 files/seahorse-0.7.5-gpg1.4.patch 2576
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
+Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFBxL35mdTrptrqvGERAr7HAJ9LfktjBn3rXQIXqvCZH/cumWVCTgCgkoTl
-E4MCSnatGHZnqrpEN+FLD0I=
-=KAod
+iD8DBQFBxX6OmdTrptrqvGERAohEAJ4kh2yoTJStIxwE2sDWeMkgF4y1UACfZHMA
+vWOG/UznqVDbjO5aw7Ekp5s=
+=6Qn6
-----END PGP SIGNATURE-----
diff --git a/app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch b/app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch
new file mode 100644
index 000000000000..6917a7a45644
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-0.7.5-gpg1.4.patch
@@ -0,0 +1,82 @@
+--- configure.in.orig 2004-11-01 03:24:04.000000000 +0930
++++ configure.in 2004-12-19 21:11:35.832207728 +0930
+@@ -52,13 +52,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -93,8 +97,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi
+--- configure.orig 2004-12-19 22:17:26.301178104 +0930
++++ configure 2004-12-19 22:17:42.260751880 +0930
+@@ -19341,13 +19341,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -19422,8 +19426,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi
diff --git a/app-crypt/seahorse/seahorse-0.7.5.ebuild b/app-crypt/seahorse/seahorse-0.7.5.ebuild
index 7c07017635d6..674e32f96742 100644
--- a/app-crypt/seahorse/seahorse-0.7.5.ebuild
+++ b/app-crypt/seahorse/seahorse-0.7.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.7.5.ebuild,v 1.5 2004/12/18 23:32:02 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.7.5.ebuild,v 1.6 2004/12/19 13:13:44 dragonheart Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="gnome front end to gnupg"
HOMEPAGE="http://seahorse.sourceforge.net/"
@@ -37,6 +37,12 @@ DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
IUSE="doc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gpg1.4.patch || die "patch failed"
+}
+
src_install() {
gnome2_src_install