summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-12-15 00:16:43 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-12-15 00:16:43 +0000
commita3201087fa32415795e961380bce62d5854fe226 (patch)
tree09b4533bdabfd1af14f5794f8ab238863f3d8816 /app-dicts/kasumi/kasumi-2.2.ebuild
parentmultilib-strict fix; bug 153978 (diff)
downloadhistorical-a3201087fa32415795e961380bce62d5854fe226.tar.gz
historical-a3201087fa32415795e961380bce62d5854fe226.tar.bz2
historical-a3201087fa32415795e961380bce62d5854fe226.zip
Version bumped.
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'app-dicts/kasumi/kasumi-2.2.ebuild')
-rw-r--r--app-dicts/kasumi/kasumi-2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-dicts/kasumi/kasumi-2.2.ebuild b/app-dicts/kasumi/kasumi-2.2.ebuild
new file mode 100644
index 000000000000..04737331c9dd
--- /dev/null
+++ b/app-dicts/kasumi/kasumi-2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.2.ebuild,v 1.1 2006/12/15 00:16:42 matsuu Exp $
+
+DESCRIPTION="Anthy dictionary maintenance tool"
+HOMEPAGE="http://kasumi.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/22902/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ nls? ( virtual/libintl )
+ virtual/libiconv
+ >=app-i18n/anthy-6131"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README ChangeLog AUTHORS
+}