summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-10-30 10:02:43 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-10-30 10:02:43 +0000
commit519b4d0c412b831dd40baf125686c8ae98b4ef3a (patch)
tree0e6f02db389e064d25f7b77fc191e4a53606353f /app-dicts
parentversion bump (diff)
downloadhistorical-519b4d0c412b831dd40baf125686c8ae98b4ef3a.tar.gz
historical-519b4d0c412b831dd40baf125686c8ae98b4ef3a.tar.bz2
historical-519b4d0c412b831dd40baf125686c8ae98b4ef3a.zip
version bump
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/stardict/Manifest6
-rw-r--r--app-dicts/stardict/files/digest-stardict-2.4.11
-rw-r--r--app-dicts/stardict/stardict-2.4.0.ebuild4
-rw-r--r--app-dicts/stardict/stardict-2.4.1.ebuild52
4 files changed, 58 insertions, 5 deletions
diff --git a/app-dicts/stardict/Manifest b/app-dicts/stardict/Manifest
index a65972ef2be2..63b3b913f50c 100644
--- a/app-dicts/stardict/Manifest
+++ b/app-dicts/stardict/Manifest
@@ -1,8 +1,8 @@
-MD5 d2f59b8e447e6dd53bbc49b61b0db67d ChangeLog 2253
+MD5 96ffc278ddd8fa8607e8905f8efbfd2c ChangeLog 2372
MD5 b1119d84c7a4c3535572b94ec508e907 metadata.xml 215
MD5 0e5909fb870eeff821ac45eda885f94a stardict-2.2.1.ebuild 1484
-MD5 57cbab64847e9f0d3b490649f76572b4 stardict-2.4.0.ebuild 1485
-MD5 edb8e48a6e6f8f7e964e9722e8c8ef82 stardict-2.4.1.ebuild 1486
+MD5 caebfb96f5f9fd2a9ed4947b853b89e7 stardict-2.4.0.ebuild 1485
+MD5 8d9caba38aaa284f457b7838e5a65939 stardict-2.4.1.ebuild 1486
MD5 3316b188ec45fd4d24db494c5990c20b files/digest-stardict-2.2.1 67
MD5 c08bafc9808a52a742f5794f68a9327b files/digest-stardict-2.4.0 67
MD5 38728c3a0ad675dd5f23d72cb143741a files/digest-stardict-2.4.1 67
diff --git a/app-dicts/stardict/files/digest-stardict-2.4.1 b/app-dicts/stardict/files/digest-stardict-2.4.1
new file mode 100644
index 000000000000..4ef09f3f3b08
--- /dev/null
+++ b/app-dicts/stardict/files/digest-stardict-2.4.1
@@ -0,0 +1 @@
+MD5 2edf73bd5d003e8223f98de00fa69aa4 stardict-2.4.1.tar.bz2 638982
diff --git a/app-dicts/stardict/stardict-2.4.0.ebuild b/app-dicts/stardict/stardict-2.4.0.ebuild
index 9c161dd3bf5f..0b00182fb10e 100644
--- a/app-dicts/stardict/stardict-2.4.0.ebuild
+++ b/app-dicts/stardict/stardict-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.0.ebuild,v 1.1 2003/09/12 19:20:49 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.0.ebuild,v 1.2 2003/10/30 10:02:39 liquidx Exp $
inherit gnome2
@@ -17,7 +17,7 @@ SRC_URI="mirror://sourceforge/stardict/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
# when adding keywords, remember to add to stardict.eclass
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
RDEPEND=">=gnome-base/libbonobo-2.2.0
diff --git a/app-dicts/stardict/stardict-2.4.1.ebuild b/app-dicts/stardict/stardict-2.4.1.ebuild
new file mode 100644
index 000000000000..828e8632f2d5
--- /dev/null
+++ b/app-dicts/stardict/stardict-2.4.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.1.ebuild,v 1.1 2003/10/30 10:02:39 liquidx Exp $
+
+inherit gnome2
+
+# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
+# their indexes seem to be in a different format. So we'll keep them
+# seperate for now.
+
+IUSE=""
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME2 international dictionary supporting fuzzy and glob style matching"
+HOMEPAGE="http://stardict.sourceforge.net/ http://cosoft.org.cn/projects/stardict/"
+SRC_URI="mirror://sourceforge/stardict/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# when adding keywords, remember to add to stardict.eclass
+KEYWORDS="~x86 ~ppc"
+
+
+RDEPEND=">=gnome-base/libbonobo-2.2.0
+ >=gnome-base/libgnome-2.2.0
+ >=gnome-base/libgnomeui-2.2.0
+ >=sys-libs/zlib-1.1.4
+ >=gnome-base/gconf-1.2
+ >=dev-libs/popt-1.7
+ >=gnome-base/ORBit2-2.6
+ >=x11-libs/gtk+-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix
+}
+
+src_install() {
+ gnome2_src_install
+ # dictionary index generation files
+ insinto /usr/share/stardict/tools
+ doins ${S}/tools/{dictd2dic,directory2dict,olddic2newdic,oxford2dic,pydict2dict,wquick2dict}
+}
+
+pkg_postinst() {
+ einfo "You will now need to install stardict dictionary files. If"
+ einfo "you have not, execute the below to get a list of dictionaries:"
+ echo
+ einfo " emerge -s stardict-"
+}