summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-22 20:34:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-22 20:34:45 +0000
commit45301b03a1285216474e6055cae39a3ad1d8d82a (patch)
tree3c2467f24d0c2f627ef57ed99105fee0a4468529 /app-doc/root-docs/files
parentImported from science overlay. Added a patch from fedora for glib-2.16. Chang... (diff)
downloadhistorical-45301b03a1285216474e6055cae39a3ad1d8d82a.tar.gz
historical-45301b03a1285216474e6055cae39a3ad1d8d82a.tar.bz2
historical-45301b03a1285216474e6055cae39a3ad1d8d82a.zip
imported from science overlay
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'app-doc/root-docs/files')
-rw-r--r--app-doc/root-docs/files/root-docs-5.34.01-makehtml.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-doc/root-docs/files/root-docs-5.34.01-makehtml.patch b/app-doc/root-docs/files/root-docs-5.34.01-makehtml.patch
new file mode 100644
index 000000000000..b339226c83d1
--- /dev/null
+++ b/app-doc/root-docs/files/root-docs-5.34.01-makehtml.patch
@@ -0,0 +1,51 @@
+--- root/Makefile.orig 2012-07-13 13:42:46.000000000 +0400
++++ root/Makefile 2012-07-22 00:15:03.282994389 +0400
+@@ -1087,16 +1087,7 @@
+
+ ifeq ($(BUILDX11),yes)
+ ifeq ($(BUILDASIMAGE),yes)
+-html: rootexecs postbin changelog releasenotes
+-ifneq ($(USECONFIG),FALSE)
+- @if [ "x`which root.exe`" != "x$(DESTDIR)$(BINDIR)/root.exe" ] \
+- || [ "`which root.exe`" -ot "bin/root.exe" ]; then \
+- echo 'ERROR: root.exe has not been installed by this build.'; \
+- echo ' Run "make install" before running "make html".'; \
+- exit 1; \
+- fi
+-endif
+- @$(MAKELOGHTML)
++html: compiledata releasenotes
+ @$(MAKEHTML)
+ else
+ html:
+--- root/build/unix/makehtml.sh.orig 2012-06-28 11:33:36.000000000 +0400
++++ root/build/unix/makehtml.sh 2012-07-22 00:18:58.705804436 +0400
+@@ -1,16 +1,16 @@
+ #! /bin/sh
+
+ dir=`pwd`
+-ROOT=$dir/bin/root
++ROOT=root
+ cd tutorials
+ # we need tutorials/hsimple.root
+ if [ ! -f hsimple.root ]; then
+- $ROOT -l -b -q hsimple.C
++ $ROOT -l -b -q hsimple.C && exit 1
+ fi
+ cd tree
+ # we need tutorials/tree/cernstaff.root
+ if [ ! -f cernstaff.root ]; then
+- $ROOT -l -b -q cernbuild.C
++ $ROOT -l -b -q cernbuild.C || exit 1
+ fi
+ cd $dir
+
+@@ -20,7 +20,7 @@
+
+ # To generate the full documentation, we do need to
+ # use the graphics engine, so do not use '-b'.
+-$ROOT -l <<makedoc
++$ROOT -l <<makedoc || exit 1
+ THtml h;
+ h.LoadAllLibs();
+ h.MakeAll();