summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2010-07-01 17:26:29 +0000
committerRyan Hill <rhill@gentoo.org>2010-07-01 17:26:29 +0000
commit7942308d8af536fa6414978d7e817d9a40274b10 (patch)
treed5c9efaa2315ea93f4a473079e4504ffbf85b409 /app-doc/tldp-howto/tldp-howto-20100701.ebuild
parentVersion bump wrt bug #309449 by Yuan Ye <yuanyelele@gmail.com> (diff)
downloadhistorical-7942308d8af536fa6414978d7e817d9a40274b10.tar.gz
historical-7942308d8af536fa6414978d7e817d9a40274b10.tar.bz2
historical-7942308d8af536fa6414978d7e817d9a40274b10.zip
Version bump. The following HOWTOs have seen updates:
- The Unix and Internet Fundamentals HOWTO - Text Terminal HOWTO - Quake HOWTO - The Software-RAID HOWTO - Software Release Practise HOWTO - The Unix Hardware Buyer HOWTO - Linux User Group HOWTO Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'app-doc/tldp-howto/tldp-howto-20100701.ebuild')
-rw-r--r--app-doc/tldp-howto/tldp-howto-20100701.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-doc/tldp-howto/tldp-howto-20100701.ebuild b/app-doc/tldp-howto/tldp-howto-20100701.ebuild
new file mode 100644
index 000000000000..c3d895ed2853
--- /dev/null
+++ b/app-doc/tldp-howto/tldp-howto-20100701.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/tldp-howto/tldp-howto-20100701.ebuild,v 1.1 2010/07/01 17:26:29 dirtyepic Exp $
+
+RESTRICT="binchecks strip"
+
+EAPI="2"
+
+inherit confutils
+
+DESCRIPTION="The Linux Documentation Project HOWTOs"
+HOMEPAGE="http://www.tldp.org"
+
+# Yay, unversioned distfiles
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/Linux-HOWTOs.tar.bz2
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html/Linux-html-HOWTOs.tar.bz2
+# ^^^ this also contains the pdfs, not sure if it's intentional as older versions don't
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html_single/Linux-html-single-HOWTOs.tar.bz2
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/pdf/Linux-pdf-HOWTOs.tar.bz2
+
+SRC_URI="
+ html? ( mirror://gentoo/Linux-html-HOWTOs-${PV}.tar.bz2 )
+ htmlsingle? ( mirror://gentoo/Linux-html-single-HOWTOs-${PV}.tar.bz2 )
+ pdf? ( mirror://gentoo/Linux-pdf-HOWTOs-${PV}.tar.bz2 )
+ text? ( mirror://gentoo/Linux-HOWTOs-${PV}.tar.bz2 )"
+
+LICENSE="FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+html htmlsingle pdf text"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ confutils_require_any html htmlsingle pdf text
+}
+
+src_unpack() {
+ mkdir -p "${S}"
+ cd "${S}"
+ if use text; then
+ mkdir "${S}"/text
+ pushd "${S}"/text > /dev/null
+ unpack Linux-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+ if use html; then
+ unpack Linux-html-HOWTOs-${PV}.tar.bz2
+ [[ -d ${S}/HOWTO/pdf ]] && rm -r "${S}"/HOWTO/pdf
+ mv "${S}"/HOWTO "${S}"/html
+ fi
+ if use htmlsingle; then
+ mkdir "${S}"/htmlsingle
+ pushd "${S}"/htmlsingle > /dev/null
+ unpack Linux-html-single-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+ if use pdf; then
+ mkdir "${S}"/pdf
+ pushd "${S}"/pdf > /dev/null
+ unpack Linux-pdf-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ if use text; then
+ docinto text
+ dodoc "${S}"/text/*
+ rm -r "${S}"/text
+ fi
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}"/*
+}