summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-04-05 18:20:51 +0000
committerKevin McCarthy <signals@gentoo.org>2011-04-05 18:20:51 +0000
commit181ce74df73fa7ae5f9781bac7b4b3fdb963059c (patch)
tree215835782c0dbf6881fd19ab6e382b051873434d /app-editors/dav/dav-0.8.5-r1.ebuild
parentDelete older ebuilds. (diff)
downloadhistorical-181ce74df73fa7ae5f9781bac7b4b3fdb963059c.tar.gz
historical-181ce74df73fa7ae5f9781bac7b4b3fdb963059c.tar.bz2
historical-181ce74df73fa7ae5f9781bac7b4b3fdb963059c.zip
Fix buffer overflow in rc parse routine. #340905
Package-Manager: portage-2.2.0_alpha29/cvs/Linux x86_64
Diffstat (limited to 'app-editors/dav/dav-0.8.5-r1.ebuild')
-rw-r--r--app-editors/dav/dav-0.8.5-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-editors/dav/dav-0.8.5-r1.ebuild b/app-editors/dav/dav-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..be5606e2057b
--- /dev/null
+++ b/app-editors/dav/dav-0.8.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dav/dav-0.8.5-r1.ebuild,v 1.1 2011/04/05 18:20:51 signals Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A minimal console text editor"
+HOMEPAGE="http://dav-text.sourceforge.net/"
+
+# The maintainer does not keep sourceforge's mirrors up-to-date,
+# so we point to the website's store of files.
+SRC_URI="http://dav-text.sourceforge.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-davrc-buffer-overflow.patch
+}
+
+src_configure() { :; }
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -lncurses" \
+ CC="$(tc-getCC)" \
+ || die "emake failed"
+}
+
+src_install() {
+ # no ./configure and doesn't hardcode /usr, so ED is fine
+ emake DESTDIR="${ED}" install || die
+ dodoc README
+}