summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-07-02 16:11:04 +0000
committerUlrich Müller <ulm@gentoo.org>2015-07-02 16:11:04 +0000
commit11a207b69076b5e4f401b6dd1c0d630a0ad1a63f (patch)
tree2820a4574de153b590a940b40df5c646670a3348 /app-editors/emacs/emacs-24.5.ebuild
parentStable for ia64, wrt bug #551010 (diff)
downloadhistorical-11a207b69076b5e4f401b6dd1c0d630a0ad1a63f.tar.gz
historical-11a207b69076b5e4f401b6dd1c0d630a0ad1a63f.tar.bz2
historical-11a207b69076b5e4f401b6dd1c0d630a0ad1a63f.zip
Repeat the warning from upstream's configure about GTK+ breakage, and display it more prominently using ewarn.
Package-Manager: portage-2.2.20/cvs/Linux x86_64 Manifest-Sign-Key: 0x9433907D693FB5B8!
Diffstat (limited to 'app-editors/emacs/emacs-24.5.ebuild')
-rw-r--r--app-editors/emacs/emacs-24.5.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-editors/emacs/emacs-24.5.ebuild b/app-editors/emacs/emacs-24.5.ebuild
index 350f350f2388..a37ab145fd4e 100644
--- a/app-editors/emacs/emacs-24.5.ebuild
+++ b/app-editors/emacs/emacs-24.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-24.5.ebuild,v 1.1 2015/04/11 08:25:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-24.5.ebuild,v 1.2 2015/07/02 16:10:59 ulm Exp $
EAPI=5
@@ -146,6 +146,15 @@ src_configure() {
local f
if use gtk; then
einfo "Configuring to build with GIMP Toolkit (GTK+)"
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your version of GTK+ will have problems with closing open
+ displays. This is no problem if you just use one display, but
+ if you use more than one and close one of them Emacs may crash.
+ See <http://bugzilla.gnome.org/show_bug.cgi?id=85715>.
+ If you intend to use more than one display, then it is strongly
+ recommended that you compile Emacs with the Athena/Lucid or the
+ Motif toolkit instead.
+ EOF
myconf+=" --with-x-toolkit=$(usex gtk3 gtk3 gtk2)"
for f in motif Xaw3d athena; do
use ${f} && ewarn \