summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
commit09a0cb6830d8c9cd82846bccece0d90c0bb30c8b (patch)
treecb24f3beb108accae6cf7aae333c349896d91687 /app-editors/vile
parentUpdate (diff)
downloadhistorical-09a0cb6830d8c9cd82846bccece0d90c0bb30c8b.tar.gz
historical-09a0cb6830d8c9cd82846bccece0d90c0bb30c8b.tar.bz2
historical-09a0cb6830d8c9cd82846bccece0d90c0bb30c8b.zip
dependencie, fhs and use fixes
Diffstat (limited to 'app-editors/vile')
-rw-r--r--app-editors/vile/vile-9.2-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-editors/vile/vile-9.2-r1.ebuild b/app-editors/vile/vile-9.2-r1.ebuild
index 0104c721010e..64457f7699cf 100644
--- a/app-editors/vile/vile-9.2-r1.ebuild
+++ b/app-editors/vile/vile-9.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.2-r1.ebuild,v 1.1 2001/04/11 03:37:30 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.2-r1.ebuild,v 1.2 2001/05/29 17:28:19 achim Exp $
A=${P}.tgz
S=${WORKDIR}/${P}
@@ -12,12 +12,18 @@ HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
DEPEND="virtual/glibc
sys-devel/flex
>=sys-libs/ncurses-5.2
- >=sys-devel/perl-5.6.0"
+ perl? ( sys-devel/perl )"
-src_compile() {
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2"
+src_compile() {
+ local myconf
+ if [ "`use perl`" ] ; then
+ myconf="--with-perl"
+ fi
try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
- --with-perl --with-ncurses
+ $myconf --with-ncurses
try make
}