summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-05-19 15:30:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-05-19 15:30:25 +0000
commitd867201dc003d3219ba1d5fc65635d84e529741d (patch)
tree70049475798bed78b49e4be2239befc8d93e7a5e /app-emacs
parentInitial revision. (diff)
downloadhistorical-d867201dc003d3219ba1d5fc65635d84e529741d.tar.gz
historical-d867201dc003d3219ba1d5fc65635d84e529741d.tar.bz2
historical-d867201dc003d3219ba1d5fc65635d84e529741d.zip
build fixes
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/w3/ChangeLog8
-rw-r--r--app-emacs/w3/files/digest-w3-4.0_pre47-r11
-rw-r--r--app-emacs/w3/files/w3-gentoo.patch29
-rw-r--r--app-emacs/w3/w3-4.0_pre47-r1.ebuild40
4 files changed, 77 insertions, 1 deletions
diff --git a/app-emacs/w3/ChangeLog b/app-emacs/w3/ChangeLog
index db1492515bb0..dd0555a5dfe1 100644
--- a/app-emacs/w3/ChangeLog
+++ b/app-emacs/w3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/w3
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/w3/ChangeLog,v 1.2 2003/02/12 03:57:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/w3/ChangeLog,v 1.3 2003/05/19 15:30:25 mkennedy Exp $
+
+*w3-4.0_pre47-r1 (19 May 2003)
+
+ 19 May 2003; Matthew Kennedy <mkennedy@gentoo.org> w3-4.0_pre47-r1.ebuild,
+ files/w3-gentoo.patch:
+ build fix
*w3-4.0_pre47 (31 Oct 2002)
diff --git a/app-emacs/w3/files/digest-w3-4.0_pre47-r1 b/app-emacs/w3/files/digest-w3-4.0_pre47-r1
new file mode 100644
index 000000000000..4d95e36afdc4
--- /dev/null
+++ b/app-emacs/w3/files/digest-w3-4.0_pre47-r1
@@ -0,0 +1 @@
+MD5 c99f44f0c7ee8609cd69512e4f587f63 w3-4.0pre.47.tar.gz 503062
diff --git a/app-emacs/w3/files/w3-gentoo.patch b/app-emacs/w3/files/w3-gentoo.patch
new file mode 100644
index 000000000000..6518c37ecf75
--- /dev/null
+++ b/app-emacs/w3/files/w3-gentoo.patch
@@ -0,0 +1,29 @@
+diff -ur w3-4.0pre.47.orig/lisp/docomp.el w3-4.0pre.47/lisp/docomp.el
+--- w3-4.0pre.47.orig/lisp/docomp.el 2001-11-28 14:04:22.000000000 -0600
++++ w3-4.0pre.47/lisp/docomp.el 2003-05-19 01:26:38.000000000 -0500
+@@ -1,22 +1,8 @@
+-;;; First things first - if they do not have the WIDGETDIR environment
+-;;; variable set, choke, scream, and die.
+-(if (or (not (getenv "WIDGETDIR"))
+- (string= (getenv "WIDGETDIR") "no"))
+- (progn
+- (message "Could not find custom libraries.")
+- (message "Please rerun `configure' in the top level directory, and")
+- (message "provide the `--with-custom=XXX' flag.")
+- (kill-emacs 1)))
+-
+ (setq load-path (append (list (expand-file-name
+- (or (getenv "W3SRCDIR") "./"))
++ (or (getenv "W3SRCDIR") "./"))
+ "."
+- (or (getenv "WIDGETDIR")
+- (expand-file-name "../widget"))
+- (or (getenv "GNUSDIR")
+- (expand-file-name "../gnus"))
+- )
+- load-path))
++ )
++ load-path))
+
+ (setq max-specpdl-size (* 10 max-specpdl-size)
+ max-lisp-eval-depth (* 10 max-lisp-eval-depth))
diff --git a/app-emacs/w3/w3-4.0_pre47-r1.ebuild b/app-emacs/w3/w3-4.0_pre47-r1.ebuild
new file mode 100644
index 000000000000..6e9d893c9e47
--- /dev/null
+++ b/app-emacs/w3/w3-4.0_pre47-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/w3/w3-4.0_pre47-r1.ebuild,v 1.1 2003/05/19 15:30:25 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="ull-featured web browser written entirely in Emacs Lisp"
+HOMEPAGE="http://www.cs.indiana.edu/elisp/w3/docs.html"
+SRC_URI="ftp://ftp.ibiblio.org/pub/packages/editors/xemacs/emacs-w3/${P/_pre/pre.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P/_pre/pre.}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && patch -p1 <${FILESDIR}/w3-gentoo.patch || die
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-emacs \
+ --with-datadir=${SITELISP}/${PN} \
+ --with-lispdir=${SITELISP}/${PN} || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr infodir=${D}/usr/share/info datadir=${D}/${SITELISP}/${PN} \
+ lispdir=${D}/${SITELISP}/${PN} install || die
+ elisp-site-file-install ${FILESDIR}/50w3-gentoo.el
+}