summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-15 22:16:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-15 22:16:29 +0000
commitdea64fd8a72f15dd0914f306e1d2de9c2a0916c5 (patch)
tree77841e12665eef6eacd034455281223b6c5ade15 /app-emulation/crossover-office-bin/crossover-office-bin-4.2.ebuild
parentexport LINGUAS to "" if everything is stripped (diff)
downloadhistorical-dea64fd8a72f15dd0914f306e1d2de9c2a0916c5.tar.gz
historical-dea64fd8a72f15dd0914f306e1d2de9c2a0916c5.tar.bz2
historical-dea64fd8a72f15dd0914f306e1d2de9c2a0916c5.zip
Version bump #89184 by Gen Zhang.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emulation/crossover-office-bin/crossover-office-bin-4.2.ebuild')
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-4.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-4.2.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-4.2.ebuild
new file mode 100644
index 000000000000..c6a84d65eedd
--- /dev/null
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-4.2.ebuild,v 1.1 2005/04/15 22:16:29 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="specialized version of wine for MS Office"
+HOMEPAGE="http://www.codeweavers.com/site/products/cxoffice/"
+SRC_URI="install-crossover-standard-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+RESTRICT="fetch nostrip"
+
+RDEPEND="virtual/x11
+ virtual/libc"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+pkg_setup() {
+ ! built_with_use dev-lang/perl ithreads \
+ && die "you need to have perl built with USE=ithreads"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}