summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 23:10:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 23:10:34 +0000
commit509ff8ffdb33d927dfa9f22084998201d6fb2d33 (patch)
tree1a2f1ccd202c2b3986e11f4d3e52c82fcb712154 /app-emulation/spectemu
parentver bump (diff)
downloadhistorical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.tar.gz
historical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.tar.bz2
historical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.zip
touch the libc
Diffstat (limited to 'app-emulation/spectemu')
-rw-r--r--app-emulation/spectemu/spectemu-0.9.4.ebuild39
1 files changed, 17 insertions, 22 deletions
diff --git a/app-emulation/spectemu/spectemu-0.9.4.ebuild b/app-emulation/spectemu/spectemu-0.9.4.ebuild
index 85f97ada4c93..88f2e1318006 100644
--- a/app-emulation/spectemu/spectemu-0.9.4.ebuild
+++ b/app-emulation/spectemu/spectemu-0.9.4.ebuild
@@ -1,38 +1,36 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/spectemu-0.9.4.ebuild,v 1.11 2004/06/24 22:34:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/spectemu-0.9.4.ebuild,v 1.12 2004/06/27 23:06:49 vapier Exp $
-IUSE="X readline svga"
+### Several versions of specemu exist, xspect & vgaspect, utilising X11
+### and/or svgalib. libreadline provides optional runtime features.
+### The ./configure script automagically figures out which binaries to build
+### so the run/compiletime dependancies here are use dependant
DESCRIPTION="48k ZX Spectrum Emulator"
HOMEPAGE="http://kempelen.iit.bme.hu/~mszeredi/spectemu/spectemu.html"
-LICENSE="GPL-2 | LGPL-2"
SRC_URI="http://home.gwi.net/~plemon/sources/spectemu-0.94.tar.gz"
-KEYWORDS="x86 ~ppc"
+
+LICENSE="GPL-2 | LGPL-2"
SLOT="0"
-### Several versions of specemu exist, xspect & vgaspect, utilising X11
-### and/or svgalib. libreadline provides optional runtime features.
-### The ./configure script automagically figures out which binaries to build
-### so the run/compiletime dependancies here are use dependant
+KEYWORDS="x86 ~ppc"
+IUSE="X readline svga"
DEPEND="X? ( virtual/x11 )
readline? ( sys-libs/readline )"
RDEPEND="svga? ( media-libs/svgalib )"
-S=${WORKDIR}/spectemu-0.94/
+S=${WORKDIR}/spectemu-0.94
src_compile() {
-
-### First we'll set compiletime options for X11 & libreadline, there are no
-### switches for svgalib, if its installed, it'll build vgaspect. if not,
-### well... it wont!
-
+ ### First we'll set compiletime options for X11 & libreadline, there are no
+ ### switches for svgalib, if its installed, it'll build vgaspect. if not,
+ ### well... it wont!
local myflags
use X || myflags="${myflags} --with-x=no"
use readline || myflags="${myflags} --without-readline"
-### and no we'll configure & compile as appropriate
-
+ ### and no we'll configure & compile as appropriate
./configure \
--host=${CHOST} \
--prefix=/usr \
@@ -43,15 +41,12 @@ src_compile() {
emake || die "Spectemu make failed"
}
-src_install () {
-
-### Here's our make install, nothing special here, houston, we are
-### go for launch.
-
+src_install() {
+ ### Here's our make install, nothing special here, houston, we are
+ ### go for launch.
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man/man1 \
infodir=${D}/usr/share/info \
install || die "Spectemu make install failed"
}
-