summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-18 11:14:30 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-18 11:14:30 +0000
commit5918ee61336a213a07ecb213d3004ae69e8a6e81 (patch)
tree3e44744ab308e7ba5c23aec131a3498d66400fec /app-emulation
parentadded local USE flag gprof for upcoming package vov (diff)
downloadhistorical-5918ee61336a213a07ecb213d3004ae69e8a6e81.tar.gz
historical-5918ee61336a213a07ecb213d3004ae69e8a6e81.tar.bz2
historical-5918ee61336a213a07ecb213d3004ae69e8a6e81.zip
Initial import.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vov/ChangeLog9
-rw-r--r--app-emulation/vov/Manifest4
-rw-r--r--app-emulation/vov/metadata.xml15
-rw-r--r--app-emulation/vov/vov-2.0.0.ebuild52
4 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/vov/ChangeLog b/app-emulation/vov/ChangeLog
new file mode 100644
index 000000000000..baf21ce0dc04
--- /dev/null
+++ b/app-emulation/vov/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/vov
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vov/ChangeLog,v 1.1 2008/02/18 11:14:30 s4t4n Exp $
+
+*vov-2.0.0 (18 Feb 2007)
+
+ 18 Feb 2007; Michele Noberasco <s4t4n@gentoo.org> vov-2.0.0.ebuild:
+ Initial import.
+
diff --git a/app-emulation/vov/Manifest b/app-emulation/vov/Manifest
new file mode 100644
index 000000000000..7fc67efcb645
--- /dev/null
+++ b/app-emulation/vov/Manifest
@@ -0,0 +1,4 @@
+DIST vov-2.0.0.tar.gz 510667 RMD160 ff86221d41d2a37962e8c290ee041773737c34a0 SHA1 86177c5bed6515bc412a8c5331541f6f38147975 SHA256 f615cec368999171d911faf539bb32db1ba58d572857b2402efa4be144463bed
+EBUILD vov-2.0.0.ebuild 1158 RMD160 8d828b7da75183d3d3e4f64d9e9899196371cfd6 SHA1 98a98f0a6634d0c524d5f97c32545ae847a677b5 SHA256 c0a9f5a6c097c6abc661c065dbc9b7add06f23c01621fe7577cec496a33973eb
+MISC ChangeLog 321 RMD160 a6db018a99651f843f40ba29c10ccad1cdc7387a SHA1 e1bb21a4364f1d16e716a8821cacb6539a1a95b2 SHA256 102b23a9c65e29af44e41100a2c87b7e8cd31a7b95f0d84e13606beab73d563b
+MISC metadata.xml 658 RMD160 0a63022181f059ab3b7a8b4a5de12460d92c5ee6 SHA1 5154d6a9fcf76d106ffb757d80c4a1503d34f527 SHA256 ca998d952222a33047c85809be92ec1ae77e32b45cf6cbf5899e205cfe77604d
diff --git a/app-emulation/vov/metadata.xml b/app-emulation/vov/metadata.xml
new file mode 100644
index 000000000000..a6a942849b9c
--- /dev/null
+++ b/app-emulation/vov/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>s4t4n@gentoo.org</email>
+ <name>Michele Noberasco</name>
+</maintainer>
+<longdescription>
+vov (Vov's Obsessive Von-Neumann) is a tool that emulates the behavior of a Von-Neumann machine.
+It is basically an interpreter, which reads files in the form of memory assignments and executes
+the encoded instructions. The vov's instructions make you able to perform simple arithmetic data
+manipulation. It is a very useful tool to see if your programs work and how.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/vov/vov-2.0.0.ebuild b/app-emulation/vov/vov-2.0.0.ebuild
new file mode 100644
index 000000000000..f74e749183b5
--- /dev/null
+++ b/app-emulation/vov/vov-2.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vov/vov-2.0.0.ebuild,v 1.1 2008/02/18 11:14:30 s4t4n Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="vov (Vov's Obsessive Von-Neumann) is a tool that emulates the behavior of a Von-Neumann machine."
+HOMEPAGE="http://home.gna.org/vov/"
+SRC_URI="http://download.gna.org/vov/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug gprof"
+
+RDEPEND="virtual/libc"
+DEPEND=">=sys-devel/flex-2.5.33-r3
+ >=sys-apps/sed-4.1.5"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # do no install redundant documentation
+ cd "${S}"
+ sed -i 's/src scripts docs/src scripts/' "${S}/Makefile.in"
+}
+
+src_compile()
+{
+ local fp_support=""
+
+ if use gprof; then
+ filter-flags "-fomit-frame-pointer"
+ fp_support="--enable-frame-pointer"
+ fi
+
+ econf \
+ `use_enable gprof` \
+ `use_enable debug` \
+ ${fp_support} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS
+ doman docs/vov.1
+}