summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-19 19:34:30 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-19 19:34:30 +0000
commite3ada04081a4cb882410abbd7f819d9abea541d5 (patch)
tree0f8052ab542cde3f2c3b2ecd02f2c5632a467ba6 /app-emulation
parentVersion bumped. (diff)
downloadhistorical-e3ada04081a4cb882410abbd7f819d9abea541d5.tar.gz
historical-e3ada04081a4cb882410abbd7f819d9abea541d5.tar.bz2
historical-e3ada04081a4cb882410abbd7f819d9abea541d5.zip
Version bumped.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/Manifest4
-rw-r--r--app-emulation/wine/files/digest-wine-200311184
-rw-r--r--app-emulation/wine/wine-20031118.ebuild126
3 files changed, 132 insertions, 2 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 599feecf325a..6b1a7dddb3d3 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,6 +1,6 @@
MD5 9bf1cedbd74c942349dea043a5c457e6 wine-20031016.ebuild 3285
-MD5 8fe40201ba02bae13839aada33266bfe wine-20031118.ebuild 3286
-MD5 f381325f15b18299960b6dee879f09e9 ChangeLog 10574
+MD5 bf8a6ecb4897cb73eeac70260c40f136 wine-20031118.ebuild 3284
+MD5 e6026154ae19e636059d45acede45ce2 ChangeLog 10695
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 f81e7076a368cabf746a5bf2902b7331 wine-20030911.ebuild 3285
MD5 bde92e756c5eaff5ee1d195d4d098cc9 files/digest-wine-20031118 282
diff --git a/app-emulation/wine/files/digest-wine-20031118 b/app-emulation/wine/files/digest-wine-20031118
new file mode 100644
index 000000000000..a820aa52359d
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20031118
@@ -0,0 +1,4 @@
+MD5 5787e6b3205b54f2230b4c4c0d422c3c Wine-20031118.tar.gz 9539006
+MD5 fa4393cbc288ea89f761ad8d9258cc68 wine-20031118-xopenfont.patch 833
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20031118-fake_windows.tar.bz2 500
+MD5 b629202e9983e301daca512f01ddbbb0 wine-20031118-misc.tar.bz2 4925
diff --git a/app-emulation/wine/wine-20031118.ebuild b/app-emulation/wine/wine-20031118.ebuild
new file mode 100644
index 000000000000..70dc633553a3
--- /dev/null
+++ b/app-emulation/wine/wine-20031118.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20031118.ebuild,v 1.1 2003/11/19 19:34:23 mholzer Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
+ mirror://gentoo/${P}-xopenfont.patch
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${P}-misc.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk nptl debug"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ epatch ${DISTDIR}/${P}-xopenfont.patch
+}
+
+src_compile() {
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ unset CFLAGS CXXFLAGS
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure \
+ --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ `use_enable opengl` \
+ `use_with nptl` \
+ `use_enable debug trace` \
+ `use_enable debug` \
+ || die "configure failed"
+
+ cd ${S}/programs/winetest
+ sed -i 's:wine.pm:include/wine.pm:' Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install() {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+}