summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-21 08:50:58 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-21 08:50:58 +0000
commit4d3fa64c97bab4221660d0fff5ddfe7b6379f360 (patch)
treee96dc75c7cb3f6c8bc2b1657816e493fb167ccca /app-gnustep/gnumail
parentNew ebuild. Finally a stable release. :) (diff)
downloadhistorical-4d3fa64c97bab4221660d0fff5ddfe7b6379f360.tar.gz
historical-4d3fa64c97bab4221660d0fff5ddfe7b6379f360.tar.bz2
historical-4d3fa64c97bab4221660d0fff5ddfe7b6379f360.zip
New ebuild. Finally a stable release. :)
Diffstat (limited to 'app-gnustep/gnumail')
-rw-r--r--app-gnustep/gnumail/Manifest4
-rw-r--r--app-gnustep/gnumail/files/digest-gnumail-1.1.01
-rw-r--r--app-gnustep/gnumail/gnumail-1.1.0.ebuild46
3 files changed, 49 insertions, 2 deletions
diff --git a/app-gnustep/gnumail/Manifest b/app-gnustep/gnumail/Manifest
index cb9b8c67f992..a55e531f1784 100644
--- a/app-gnustep/gnumail/Manifest
+++ b/app-gnustep/gnumail/Manifest
@@ -1,7 +1,7 @@
-MD5 538f8cd0ecfc704a7cdbc082c9484914 gnumail-1.1.0.ebuild 1108
+MD5 9afd080bb8b768526284d2d507c84dd8 gnumail-1.1.0.ebuild 1100
MD5 1c3203f88f208a9a76d5d3a252bcdbc1 gnumail-1.1.0_pre2-r1.ebuild 1114
MD5 8e1cff2c8692abed8deffa3fb676e7b7 gnumail-1.1.0_pre2.ebuild 680
-MD5 d74764d4bc55d53c9a67423daac3ad94 ChangeLog 615
+MD5 743742f2bf1f40d09d654a0c69f7fadf ChangeLog 758
MD5 80699754a7e9adb6c02df33c8fa16fd6 metadata.xml 161
MD5 9102b5426c1a0e7dc045d14ef6899cc8 files/digest-gnumail-1.1.0_pre2-r1 69
MD5 a6afb5fd55515a881cc64e0b5f2667d9 files/digest-gnumail-1.1.0 66
diff --git a/app-gnustep/gnumail/files/digest-gnumail-1.1.0 b/app-gnustep/gnumail/files/digest-gnumail-1.1.0
new file mode 100644
index 000000000000..81a08ea226a1
--- /dev/null
+++ b/app-gnustep/gnumail/files/digest-gnumail-1.1.0
@@ -0,0 +1 @@
+MD5 8b9d1030849dbc91c2d28716c6fceef2 GNUMail-1.1.0.tar.gz 1002575
diff --git a/app-gnustep/gnumail/gnumail-1.1.0.ebuild b/app-gnustep/gnumail/gnumail-1.1.0.ebuild
new file mode 100644
index 000000000000..8f98b9980d3a
--- /dev/null
+++ b/app-gnustep/gnumail/gnumail-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-gnustep/gnumail/gnumail-1.1.0.ebuild,v 1.1 2003/08/21 08:50:54 g2boojum Exp $
+
+inherit gnustep
+
+newdepend dev-util/gnustep-gui
+newdepend app-gnustep/pantomime
+
+S=${WORKDIR}/GNUMail
+A=GNUMail-${PV}.tar.gz
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+LICENSE="GPL-2"
+DEPEND="${DEPEND}"
+RDEPEND="${RDEPEND} dev-util/gnustep-back"
+SRC_URI="http://www.collaboration-world.com/gnumail.data/releases/Stable/GNUMail-${PV}.tar.gz"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+IUSE="${IUSE} xface crypt"
+
+src_compile() {
+
+ egnustepmake
+
+ if [ "`use xface`" ]; then
+ cd ${S}/Bundles/Face
+ make
+ cd ${S}
+ fi
+
+ if [ "`use crypt`" ]; then
+ cd ${S}/Bundles/PGP
+ make
+ cd ${S}
+ fi
+}
+
+src_install() {
+ egnustepinstall
+
+ use xface && cp -a ${S}/Bundles/Face/Face.bundle ${D}usr/GNUstep/System/Library/GNUMail/
+
+ use crypt && cp -a ${S}/Bundles/PGP/PGP.bundle ${D}usr/GNUstep/System/Library/GNUMail/
+}