summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-06-20 17:48:21 +0000
committerMamoru Komachi <usata@gentoo.org>2004-06-20 17:48:21 +0000
commit1a92adc6b0ea32b2da64bd96ee5bbd3f7ed3f068 (patch)
treeb3c5c1286e0611cd93cd3d190b246122bb79c045 /app-i18n/scim-m17n/scim-m17n-0.1.0.ebuild
parentVErsion bumped. (diff)
downloadhistorical-1a92adc6b0ea32b2da64bd96ee5bbd3f7ed3f068.tar.gz
historical-1a92adc6b0ea32b2da64bd96ee5bbd3f7ed3f068.tar.bz2
historical-1a92adc6b0ea32b2da64bd96ee5bbd3f7ed3f068.zip
Version bumped. Ebuilds cleanup.
Diffstat (limited to 'app-i18n/scim-m17n/scim-m17n-0.1.0.ebuild')
-rw-r--r--app-i18n/scim-m17n/scim-m17n-0.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-i18n/scim-m17n/scim-m17n-0.1.0.ebuild b/app-i18n/scim-m17n/scim-m17n-0.1.0.ebuild
new file mode 100644
index 000000000000..3cabc4fea21e
--- /dev/null
+++ b/app-i18n/scim-m17n/scim-m17n-0.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-m17n/scim-m17n-0.1.0.ebuild,v 1.1 2004/06/20 17:48:21 usata Exp $
+
+DESCRIPTION="scim-m17n is an input module for Smart Common Input Method (SCIM) which uses m17n as backend"
+HOMEPAGE="http://freedesktop.org/~suzhe/"
+SRC_URI="http://freedesktop.org/~suzhe/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=app-i18n/scim-0.99.0_pre20040614
+ >=dev-libs/m17n-lib-1.0.2-r1"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -f socket -e m17n -c simple -d"
+ einfo "LANG='your_language' scim -f x11 -e socket -c socket -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo
+}