summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-30 22:18:40 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-30 22:18:40 +0000
commit5d922e8a3c1c249582eb8eaea5e0e20cbadc59c6 (patch)
tree5006f9edc614b878a7c54a4f63e1459d95092fad /app-misc
parentfixed the quanta-dosc ebuild, which didn't work at all. i'll do soem more fix... (diff)
downloadhistorical-5d922e8a3c1c249582eb8eaea5e0e20cbadc59c6.tar.gz
historical-5d922e8a3c1c249582eb8eaea5e0e20cbadc59c6.tar.bz2
historical-5d922e8a3c1c249582eb8eaea5e0e20cbadc59c6.zip
New working xscreensaver
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xscreensaver/files/digest-xscreensaver-3.341
-rw-r--r--app-misc/xscreensaver/xscreensaver-3.32-r2.ebuild115
-rw-r--r--app-misc/xscreensaver/xscreensaver-3.34.ebuild82
3 files changed, 139 insertions, 59 deletions
diff --git a/app-misc/xscreensaver/files/digest-xscreensaver-3.34 b/app-misc/xscreensaver/files/digest-xscreensaver-3.34
new file mode 100644
index 000000000000..3ecf92441c03
--- /dev/null
+++ b/app-misc/xscreensaver/files/digest-xscreensaver-3.34
@@ -0,0 +1 @@
+MD5 8243473e811c7e445e5e3cb60334ef0d xscreensaver-3.34.tar.gz 1662976
diff --git a/app-misc/xscreensaver/xscreensaver-3.32-r2.ebuild b/app-misc/xscreensaver/xscreensaver-3.32-r2.ebuild
index b392de429ec2..efdae50a269a 100644
--- a/app-misc/xscreensaver/xscreensaver-3.32-r2.ebuild
+++ b/app-misc/xscreensaver/xscreensaver-3.32-r2.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xscreensaver/xscreensaver-3.32-r2.ebuild,v 1.1 2001/10/06 12:36:36 azarah Exp $
+# Maintainer: Martin Schlemmer <azarah@gento.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xscreensaver/xscreensaver-3.32-r2.ebuild,v 1.2 2001/12/30 22:18:40 drobbins Exp $
#P=
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="a modular screensaver for X11"
-SRC_URI="http://www.jwz.org/xscreensaver/${A}"
+SRC_URI="http://www.jwz.org/xscreensaver/${P}.tar.gz"
HOMEPAGE="http://www.jwz.org/xscreensaver/"
DEPEND="virtual/x11 sys-devel/bc
@@ -15,71 +14,69 @@ DEPEND="virtual/x11 sys-devel/bc
motif? ( >=x11-libs/openmotif-2.1.30 )
opengl? ( virtual/opengl >=media-libs/gle-3.0.1 )
gnome? ( >=gnome-base/control-center-1.4.0.1-r1 )
- pam? ( >=sys-libs/pam-0.75 )
- kde? ( kde-base/kde-env )"
+ pam? ( >=sys-libs/pam-0.75 )
+ kde? ( kde-base/kde-env )"
RDEPEND="virtual/x11
gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
motif? ( >=x11-libs/openmotif-2.1.30 )
opengl? ( virtual/opengl >=media-libs/gle-3.0.1 )
gnome? ( >=gnome-base/control-center-1.4.0.1-r1 )
- pam? ( >=sys-libs/pam-0.75 )
- kde? ( kde-base/kde-env )"
+ pam? ( >=sys-libs/pam-0.75 )
+ kde? ( kde-base/kde-env )"
src_compile() {
- local myconf
- if [ "`use gnome`" ]
- then
- myconf="--with-gnome"
- else
- myconf="--without-gnome"
- fi
- if [ "`use gtk`" ]
- then
- myconf="$myconf --with-gtk"
- else
- myconf="$myconf --without-gtk"
- fi
- if [ "`use motif`" ]
- then
- myconf="$myconf --with-motif"
- else
- myconf="$myconf --without-motif"
- fi
- if [ "`use pam`" ]
- then
- myconf="$myconf --with-pam"
- else
- myconf="$myconf --without-pam"
- fi
- if [ "`use opengl`" ]
- then
- myconf="$myconf --with-gl --with-gle"
- else
- myconf="$myconf --without-gl --without-gle"
- fi
-
-
- try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
- --enable-subdir=/usr/lib/xscreensaver $myconf \
- --with-mit-ext --with-dpms-ext --with-xf86vmode-ext \
- --with-proc-interrupts --with-xpm --with-xshm-ext \
- --with-xdbe-ext --enable-locking
- try make
+ local myconf
+ if [ "`use gnome`" ]
+ then
+ myconf="--with-gnome"
+ else
+ myconf="--without-gnome"
+ fi
+ if [ "`use gtk`" ]
+ then
+ myconf="$myconf --with-gtk"
+ else
+ myconf="$myconf --without-gtk"
+ fi
+ if [ "`use motif`" ]
+ then
+ myconf="$myconf --with-motif"
+ else
+ myconf="$myconf --without-motif"
+ fi
+ if [ "`use pam`" ]
+ then
+ myconf="$myconf --with-pam"
+ else
+ myconf="$myconf --without-pam"
+ fi
+ if [ "`use opengl`" ]
+ then
+ myconf="$myconf --with-gl --with-gle"
+ else
+ myconf="$myconf --without-gl --without-gle"
+ fi
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --enable-subdir=/usr/lib/xscreensaver $myconf \
+ --with-mit-ext --with-dpms-ext --with-xf86vmode-ext \
+ --with-proc-interrupts --with-xpm --with-xshm-ext \
+ --with-xdbe-ext --enable-locking || die
+ emake || die
}
src_install () {
- if [ "$KDEDIR" ]
- then
- dodir $KDEDIR/bin
- fi
- try make install_prefix=${D} install
- if [ "`use gnome`" ]
- then
- dodir /usr/bin
-# not need i think, shout if it breaks control-center support
-# mv ${D}/usr/bin/screensaver-properties-capplet ${D}/usr/bin
- fi
+ if [ "$KDEDIR" ]
+ then
+ dodir $KDEDIR/bin
+ fi
+ make install_prefix=${D} install || die
+# if [ "`use gnome`" ]
+# then
+# #dodir /usr/bin
+# # not need i think, shout if it breaks control-center support
+# # mv ${D}/usr/bin/screensaver-properties-capplet ${D}/usr/bin
+# fi
}
diff --git a/app-misc/xscreensaver/xscreensaver-3.34.ebuild b/app-misc/xscreensaver/xscreensaver-3.34.ebuild
new file mode 100644
index 000000000000..9109879b0546
--- /dev/null
+++ b/app-misc/xscreensaver/xscreensaver-3.34.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gento.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xscreensaver/xscreensaver-3.34.ebuild,v 1.1 2001/12/30 22:18:40 drobbins Exp $
+
+#P=
+S=${WORKDIR}/${P}
+DESCRIPTION="a modular screensaver for X11"
+SRC_URI="http://www.jwz.org/xscreensaver/${P}.tar.gz"
+HOMEPAGE="http://www.jwz.org/xscreensaver/"
+
+DEPEND="virtual/x11 sys-devel/bc
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ opengl? ( virtual/opengl >=media-libs/gle-3.0.1 )
+ gnome? ( >=gnome-base/control-center-1.4.0.1-r1 )
+ pam? ( >=sys-libs/pam-0.75 )
+ kde? ( kde-base/kde-env )"
+
+RDEPEND="virtual/x11
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ opengl? ( virtual/opengl >=media-libs/gle-3.0.1 )
+ gnome? ( >=gnome-base/control-center-1.4.0.1-r1 )
+ pam? ( >=sys-libs/pam-0.75 )
+ kde? ( kde-base/kde-env )"
+
+src_compile() {
+ local myconf
+ if [ "`use gnome`" ]
+ then
+ myconf="--with-gnome"
+ else
+ myconf="--without-gnome"
+ fi
+ if [ "`use gtk`" ]
+ then
+ myconf="$myconf --with-gtk"
+ else
+ myconf="$myconf --without-gtk"
+ fi
+ if [ "`use motif`" ]
+ then
+ myconf="$myconf --with-motif"
+ else
+ myconf="$myconf --without-motif"
+ fi
+ if [ "`use pam`" ]
+ then
+ myconf="$myconf --with-pam"
+ else
+ myconf="$myconf --without-pam"
+ fi
+ if [ "`use opengl`" ]
+ then
+ myconf="$myconf --with-gl --with-gle"
+ else
+ myconf="$myconf --without-gl --without-gle"
+ fi
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --enable-subdir=/usr/lib/xscreensaver $myconf \
+ --with-mit-ext --with-dpms-ext --with-xf86vmode-ext \
+ --with-proc-interrupts --with-xpm --with-xshm-ext \
+ --with-xdbe-ext --enable-locking || die
+ emake || die
+}
+
+src_install () {
+ if [ "$KDEDIR" ]
+ then
+ dodir $KDEDIR/bin
+ fi
+ make install_prefix=${D} install || die
+# if [ "`use gnome`" ]
+# then
+# #dodir /usr/bin
+# # not need i think, shout if it breaks control-center support
+# # mv ${D}/usr/bin/screensaver-properties-capplet ${D}/usr/bin
+# fi
+}
+